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General tips and reminders 

This document provides instructions for the year-end closing for Microsoft Dynamics GP 2018 and GP 

18.x With the exception of the information provided on the Year-End Update and a few minor changes, 

most of the procedures are applicable to prior versions. Please note the information contained in the 

sections entitled “Payables Management Year-End Closing” and “Payroll Year-End Closing Procedures” 

regarding the 2022 Year End Update and 2023 Tax Updates. If you are on GP 18.XX, you may require an 

additional update prior installing the 2022 Year End Update version 18.5.1596. Please refer to Microsoft's 

upgrade details in the link below: 

Upgrading to Microsoft Dynamics GP 

Many of the items are marked as “Optional.” We suggest that you review these optional steps and decide 

what is relevant and feasible for your business. All the procedures marked as “Optional” are considered 

best practices, and we highly recommend that you consider these steps when making decisions 

regarding year-end. 

Backups 

Backups are an important component of a closing process. Some closing procedures recommend 

numerous backups throughout the process. We limit our backup recommendations in this document to a 

few critical points. How often you perform a backup during the closing process will vary depending on the 

amount of space available on your server, the number of modules you are closing at one time and the 

number of steps involved in closing a particular module. Most companies will have their information 

technology (IT) staff create backups on the structured query language (SQL) server. However, you can 

also make a backup within Microsoft Dynamics GP by following these steps: 

Note:  All users must exit the company database prior to making a backup of the database. The Backup 

Company window is only available when using a Microsoft Dynamics GP installation on the SQL Server. 

Only a system administrator can open the Backup Company window to make backups. 

Go to Microsoft Dynamics GP > Maintenance > Backup  

In the Backup Company Window, select the company name in the Company Name list.  

Change the path of the backup file if it is required, and then click OK. 

Timing 

Fixed Assets and Inventory are considered date-sensitive modules. Because these modules are date-

sensitive, you may not post transactions into the next fiscal year and run the Year-End closing process at 

a later time. You must run the Year-End Close at the end of the fiscal year prior to entering transactions 

for the next fiscal year.   

Receivables Management and Payables Management are also date-sensitive modules in certain areas. If 

you are currently tracking your Customer/Vendor statistics using any of the following:  

Receivables/Payables Summary Reports, Smart Lists or the summary windows, such as the “Amounts 

https://learn.microsoft.com/en-us/dynamics/s-e/gp/hot_topic_mdgpupgrade_415
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Since Last Close” view, you will want to process the fiscal and calendar year-end close prior to posting 

transactions for the new year. 

It is important to understand that if you elect to either delay OR not to run the closing procedure at all in 

Receivables Management or Payables Management prior to processing transactions for the new year, 

the figures in the “Amounts Since Last Close” view in the Vendor summary windows will be incorrect, as 

well as many of the reports and Smart Lists that contain Customer/Vendor statistics. The tables that hold 

this information get updated during the close process, so if the close is not done on time, the figures will 

be skewed. 

History 

If you are keeping several years of history, year-end is perhaps a good time to consider removing history, 

especially if you have limited space. Contact your local RSM representative or RSM support for 

assistance with removing history.   

File maintenance (Optional) 

If you are not already performing regular database maintenance routines on your system, we recommend 

that you perform Check Links on each of the modules before closing. Run the process for one series at a 

time and choose to include all tables. The error log can be printed to the screen initially and sent to the 

printer if there are any errors to review. Depending on the size of your data, you may want to run this 

process overnight or over the weekend. 

Go to Microsoft Dynamics GP > Maintenance > Check Links 

Year-end closing sequence 

Year-end closing should be performed in the following order: 

1. Inventory 

2. Receivables Management  

3. Payables Management 

4. Fixed Assets 

5. Analytical Accounting 

6. General Ledger 

Note: Payroll year-end procedures are independent of those in other modules and are always performed 

at the calendar year-end. 

Note: The Sales Order Processing and Purchase Order Processing modules have no REQUIRED Year-

End Close procedures. The year-end steps outlined in this document for sales order processing (SOP) 

and purchase order processing (POP) are noted as OPTIONAL and are the same as your typical Month-

End procedures. We do recommend that you run the Reconcile Utility described in the next section on 
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ALL of the Distribution Modules. These procedures are considered to be best practices for maintaining 

your system.    

Reconcile 

We recommend that you run the reconcile procedures in Microsoft Dynamics GP in the following order: 

Step 1: Reconcile Sales Order Processing  

Go to Microsoft Dynamics GP > Tools > Utilities > Sales > Reconcile – Remove Sales Documents 

Step 2: Reconcile Purchase Order Processing 

Go to Microsoft Dynamics GP > Tools > Utilities > Purchasing > Reconcile Purchasing Documents  

Step 3: Reconcile Inventory 

Go to Microsoft Dynamics GP > Tools > Utilities > Inventory > Reconcile  

Step 4: Reconcile Project Accounting 

Note: This step is required only if you are using Project Accounting. 

Go to Microsoft Dynamics GP > Tools > Utilities > Project > PA Reconcile IV 

Step 5: Reconcile Field Service 

Note: This step is required only if you are using any of the Field Service functionalities. This step 

reconciles all of the Field Service modules. 

Go to Microsoft Dynamics GP > Tools > Utilities > Project > Service Utilities > Reconcile Quantities 
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Sales order processing year-end procedures 
(OPTIONAL) 

The year-end procedures are the same as the month-end procedures for sales order processing. If you 

have not been performing these tasks on a monthly basis, please do so at year-end. 

Sales order processing year-end checklist 

1. Reconcile Sales Documents 

2. Remove Completed Sales Documents 

3. Print the Month-End reports (Optional) 

Detailed information for each step in the year-end checklist 

Step 1: Reconcile Sales Documents 

The reconcile process checks the subtotals of all documents in the range you have selected and 

recalculates any that are incorrect. The reconcile also verifies batch controls, checks the remaining 

quantity subtotals, verifies fulfilled quantities for serial- or lot-numbered items and verifies quantities on 

documents.  

Go to Microsoft Dynamics GP > Tools > Utilities > Sales > Reconcile-Remove Sales Documents 

 

Select the range of sales documents you wish to reconcile. 

Mark the Reconcile Sales Documents option. 

1. If you select the Print Report Only option, a report will be printed showing the documents that will 

be reconciled based on the range entered. Printing the report only will not adjust any quantities 

on any documents.  

2. If you select Print Report Only, along with Reconcile Sales Documents, the report will show you 

details of the documents actually reconciled during the process. 

3. Select Process to reconcile the selected range of sales documents. When the reconcile process 

is complete, a report will print listing the details of any changes made to sales documents. 
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Step 2: Remove completed sales documents 

Removing completed documents pertains to quotes, orders, invoices and back orders only. Completed 

documents are removed from the work file and moved to the history file, if you are keeping history. 

A document is considered completed if it does not contain a deposit and if all line items have a remaining 

quantity of zero. 

Repeating quotes and orders will also be checked. If the “times repeated” equals the “times to repeat,” 

the document is considered complete and will be removed if it is included in the selected range. 

Typically, completed documents are removed from the work file and moved to the history file (if keeping 

history) during the transfer process. However, there may be cases when the quantity remaining on an 

order or back order may be cancelled. Since there are no remaining quantities to transfer, the document 

will remain in the work file until it is removed using this process. 

1. Go to Microsoft Dynamics GP > Tools > Utilities > Sales > Reconcile-Remove Sales Documents. 

 

2. Select the range of sales documents you wish to remove to History. 

3. Mark the Remove Completed Documents option. If you select the Print Report Only option, a 

report will be printed showing the documents that will be reconciled based on the range entered. 

Printing the report only will not move any documents to history. 

4. If you select Print Report Only, along with Remove Completed Documents, the report will show 

you details of the documents actually moved to History during the process. 

5. Select Process to remove to History the selected range of sales documents. When the reconcile 

process is complete, a report will print listing the details of any changes made to sales 

documents. 

Step 3: Print the following Month-End Reports (Optional): 

• Sales Document Analysis Report (Reports > Sales > Analysis) 

• Inventory Sales Report (Reports > Sales > Analysis) 

• Sales Transaction History (Reports > Sales > History) 

• Sales Serial/Lot History Report, if applicable (Reports > Sales > History)
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Purchase order year-end closing procedures 
(OPTIONAL) 

The year-end procedures are the same as the month-end procedures for purchase order processing. If 

you have not been performing these tasks on a monthly basis, please do so at year-end. 

Purchase order year-end checklist 

1. Reconcile Purchasing Documents 

2. Remove Completed Purchase Orders 

3. Print the Month-End reports (Optional) 

Detailed information for each step in the year-end checklist 

Step 1: Reconcile purchasing documents 

Reconciling is the process of verifying that the totals on your purchase orders match the totals recorded in 

your accounting records. When you reconcile purchase orders, the following will be recalculated and 

adjusted if necessary: 

• Document quantity cancelled 

• Document subtotals 

• Document extended costs and remaining quantities 

• Remaining purchase order subtotals 

• Purchase order status 

• Line item status 

• Line item extended cost 

• Discount available 

• Trade discount 

Reconcile Purchase Orders assumes that line item information is correct. Document totals will be 

reconciled to match line item detail amounts and quantities. 

Before running the Reconcile Payables Accounts utility in Payables Management or the Reconcile 

Inventory Quantities utility in Inventory, run the Reconcile Purchase Orders utility in Purchase Order 

Processing. It is important that the purchasing documents are correct, since purchasing information may 

be altered, and is used when Reconcile Inventory Quantities and Reconcile Payables Accounts utilities 

are performed. 

Before reconciling Purchase Orders, backup your company’s data files or database. 
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Go to Microsoft Dynamics GP > Tools > Utilities > Purchasing > Reconcile Purchasing Documents 

 

Indicate whether you want to reconcile information for all purchase orders or for a selected range. If you 

are creating a range, you must enter at least one value in the Restrictions fields. Select the first and last 

purchase orders in the desired range. 

Select the option to Reconcile and Print Report or Print Report Only. 

If you select the Print Report Only option before you reconcile and print, you can verify the accuracy of 

which documents in the range will be reconciled before you actually reconcile the documents. 

Choose Process  

When processing is complete, the Reconcile Purchasing Documents report will print. This report lists the 

purchasing documents that were reconciled. 

Note:  If the Reconcile Purchasing Documents report indicates that an amount has been adjusted for a 

specific purchasing document, review the document to verify the accuracy of the changes that were 

made. 

Step 2: Remove Completed Purchase Orders 

Use the Remove Completed Purchase Orders window to remove any closed or cancelled documents 

from the “Open” Purchase Order Work table to the Purchase Order History table. 

It is important to make sure that you have marked the options to Maintain History for Purchase Orders, 

Account Distributions and Receipts in the Purchase Order Processing Setup window under: Tools > 

Setup > Purchasing > Purchase Order Processing. If the checkboxes in this window are NOT marked, 

this process will completely DELETE the documents from your system. If the checkboxes are marked, 

then it will only move them from the Open table to the History table. You should move or remove your 

completed purchase orders periodically. Purchase Orders should be moved or removed after you no 

longer need to receive them or when you no longer need to reject or cancel any items on the purchase 

orders. 

Before removing completed purchase orders, backup your company’s data files or database. 

Go to Microsoft Dynamics GP > Tools > Routines > Purchasing > Remove Completed Purchase Orders 
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Select to remove information for purchase orders by the purchase order (PO) Number, Vendor ID, Vendor 

Name, Document Date or the Created by User ID, and then enter the first and last records in the selected 

range. 

Note: If you enter a value in only one of the restriction fields, completed purchase orders will be removed 

from the value you enter to either the beginning or end of the records. For example, if you enter a starting 

value and leave the ending value blank, all completed purchase orders from the starting value to the end 

of the records will be removed. 

Choose Insert to select the range of documents you’ve chosen to remove. You can only insert one 

restriction for each document range. For example, you can insert one PO Number restriction and one 

Vendor ID restriction. 

To further customize your restrictions, choose Restrictions to open the Restrict Purchasing Documents 

window. The documents selected on the Remove Completed Purchase Orders window will be displayed. 

Use this window to selectively mark or unmark the documents you wish to remove. When you’ve finished 

setting restrictions in the Remove Completed Purchase Orders window or the Restrict Purchasing 

Documents window, choose Process. When processing is complete, the Completed PO Removal 

Report prints, listing the purchase orders that were removed. 

Step 3: Print the following month-end reports (Optional): 

• Received/Not Invoiced Report (Reports > Purchasing > Analysis) 

Note: Items appear on the Received/Not Invoiced report when the receipt of the goods is 

posted. The records will disappear from the report when the invoice is matched and saved. 

This means that the report will not match the Accrued Purchases account in the general 

ledger as long as there are any unposted invoices in Purchase Order Processing. 

• Purchase Order Status Report (Reports > Purchasing > Analysis) 

• Shipment/Invoice Matching Activity Report (Reports > Purchasing > Analysis) 

• Receivings Transaction History Report (Reports > Purchasing > History)
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Inventory control year-end closing procedures 

Closing a year transfers all summarized current-year quantity, cost and sales amounts to transaction 

history for the items for which you've been keeping summarized sales history. This procedure also 

updates each item's beginning quantity to the quantity on hand at each site. 

Inventory control year-end checklist 

1. Post all transactions for the year 

2. Reconcile inventory quantities 

3. Complete a physical inventory count and post any adjustments 

4. Print additional reports 

5. Make a backup 

6. Close the year 

7. Close the fiscal periods for the inventory series (optional) 

Detailed information for each step in the year-end checklist 

Step 1: Post all transactions for the year 

Be sure that all Invoicing, Sales Order Processing and Inventory transactions for the current year have 

been entered and posted before you close the year. This is important to ensure that historical information 

is accurate for the year you are closing and year-to-date amounts are accurately stated for the year. If 

you wish to enter future-period transactions before closing the year, create a new batch with new 

transactions, but don't post it until after the year has been closed.  

Step 2: Reconcile Inventory Quantities 

Go to Microsoft Dynamics GP > Tools > Utilities > Inventory > Reconcile 

 

To ensure the integrity of your Inventory data, we recommend that you reconcile quantities for all 

Inventory items using the Reconcile Inventory Quantities window. If any discrepancies are found during 

the Reconcile process, the quantities will be adjusted. If adjustments are made, they will be reflected on 

the Reconcile Report, along with any serial numbers and lot numbers that were added or deleted for the 

adjusted items. If you want to edit these serial and lot numbers, you can use the Item Transaction Entry 

window to make adjustment transactions. (Transactions > Inventory > Transaction Entry) 
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Step 3: Complete a physical inventory count and post any adjustments 

Method 1 – Stock Count Procedure 

1. Go to Microsoft Dynamics GP > Tools > Setup > Inventory > Stock Calendar. 

Use the Stock Calendar Maintenance window to set up and maintain information about when 

stock counts can be performed and which days will be “counted” when the system calculates 

suggested dates for the next stock count for a specific item-site combination.  

2. Go to Cards > Inventory > Count Cycle Assignment.  

The Stock Count Cycle Assignment window can be used if desired to assign one stock count 

frequency to many items.   

3. Go to Transactions > Inventory > Stock Count Schedule. 

4. Create a Stock Count Schedule, a list of the specific items at a specific site that will be counted 

during a specific count. When you start a stock count schedule, the quantity on hand for each line 

in the stock count schedule is captured. Later, the actual count number quantities will be 

compared to the captured values to create default variance transactions. Stock Count Forms can 

be printed during this process.  

5. Go to Transactions > Inventory > Stock Count Entry. 

6. Use the Stock Count Entry window to enter information about the results of your stock counts. 

When you process a stock count, variance transactions are created. If the Auto Post Stock Count 

Variance’s option is marked, the transactions also will be posted.  

Method 2 – Inventory Manual Transaction Entry 

You also have the option to manually create your inventory adjusting entries. First, print a Physical 

Inventory Checklist, using the Inventory Activity Reports window, and perform a physical count of your 

inventory items to verify that Quantity on Hand amounts are accurate for all items.  

1. Go to Reports > Inventory > Activity > Physical Inventory Checklist. 

If discrepancies exist, enter the necessary adjustments in the Item Transaction Entry window.  

2. Transactions > Inventory > Transaction Entry 
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Step 4: Print Additional Reports 

Print any additional reports from the selections under Reports > Inventory you will need for planning or 

your permanent records, including the following reports: 

• Historical Stock Status Report–Reports > Inventory > Activity – Historical Stock Status 

• Purchase Receipts Report–Reports > Inventory > Activity – Purchase Receipts 

• Turnover Report–Reports > Inventory > Analysis > Turnover 

• Transaction History Report–Reports > Inventory > History > Transaction History 

• Serial Number List–Reports > Inventory > Serial/Lots > Serial Number 

• Lot Number List–Reports > Inventory > Serial/Lots > Lot Number 

Note: If you plan to remove sold purchase receipts during the year-end closing process, we recommend 

that you print the Purchase Receipts Report to review the receipts that will be removed. 

Step 5: Make a backup 

Make a backup before you close the year. Place the backup in safe, permanent storage. This backup 

ensures that you have a permanent record of the company's financial position at the end of the year and 

allows you to quickly restore the information in the event a power fluctuation or some other problem 

occurs during the year-end close procedure. See the section on Backups under General Tips and 

Reminders for more information on creating backups.   

Step 6: Close the year 

The Inventory year-end closing accomplishes the following tasks:  

• Transfers all summarized, current-year quantity, cost and sales amounts to transaction history for 

the items for which you've been keeping summarized sales histories.  

• Updates the item's Beginning Quantity to the Quantity On Hand at each site. Certain reports, 

such as the Turnover Report, use the beginning quantity field for report calculations. 

• Zeros the Quantity Sold field in Item Quantities Maintenance (Cards > Inventory > Items 

Qtys/Sites) for each site.  

• Removes Purchase Receipts for items that have been completely sold.  

• Removes any discontinued items from the Item records that have been completely sold.  

• Removes any Lot attributes from the records of Lot Numbered Items if they have been completely 

sold.  
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Updates the Standard Cost of each item to the current cost if you're using either the First In, First Out 

(FIFO) periodic or Last In, First Out (LIFO) periodic Valuation Methods. This feature does not occur if 

using Manufacturing. 

To close the year in Inventory: 

1. Go to Microsoft Dynamics GP > Tools > Routines > Inventory > Year-End Close. 

 

2. Remove Discontinued Items: If you mark the Discontinued Items option, all discontinued items 

that have a zero balance will be removed during the year-end closing process. (Items can be 

designated as discontinued using the Item Maintenance window.) Discontinued items that have a 

Quantity On Hand of zero (except for kit components), and do not have any unposted 

transactions, will be completely removed from the Inventory module.  

Note: If using the Service Call Management module, verify whether any discontinued Items exist 

on any unposted service documents. If so, the documents must be posted before proceeding. 

The Sales Order Processing, Invoicing or Purchase Order Processing reports and inquiries will 

still be able to pull information regarding these discontinued Items; however, you will not be able 

to do a lookup on the Item Number, since it has been removed from the Item Master. If you would 

like to print a report or inquire on the discontinued Item, you will need to include the item within 

the Item Number Range. 

Note: If you select this option, you will remove the discontinued items. Additionally, you will 

remove all inventory history for the items. You will not be able to drill back on the inventory history 

for these items. 

3. Remove Sold Lot Attributes: If you mark Sold Lot Attributes, values for completely sold lot 

numbers will be removed. (For example, you can remove the value “red” for the lot attribute color 

if you have sold all lot-numbered items that have been assigned the value “red.”) 

4. Remove Sold Receipts and Cost Change History Prior to xx/xx/xx date: If you mark Sold Receipts 

and Cost Change History and enter a date, all sold purchase receipts, quantity-sold details and 

historical cost changes with dates that come before the date that you have entered for items that 

use the Average Perpetual, LIFO Periodic or FIFO Periodic valuation methods will be removed. 

The sold receipts, quantity-sold details and historical cost changes with dates that come before 

the date that you’ve entered will be removed. 
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Before removing all sold receipts and historical cost changes, you should print a Purchase 

Receipts Report and review the receipts that will be removed. 

5. Update Item’s Standard Cost: If you mark Item's Standard Cost, the standard cost for any items 

that have been assigned the FIFO periodic or LIFO periodic valuation methods will be adjusted 

automatically to reflect each item's current cost or the amount you most recently paid for the item. 

 

When you have selected your options, click Process to begin the year-end closing process. While 

the year-end close routine is running, users will not be able to post inventory transactions, 

reconcile quantities, change valuation methods or change decimal places for items.   

Step 7: Close the fiscal periods for the Inventory Series (Optional) 

To ensure that no one posts transactions to an incorrect period or year, use the Fiscal Periods Setup 

window to close any fiscal periods that are still open for the year. 

1. Go to Microsoft Dynamics GP > Tools > Setup > Company > Fiscal Periods. 

Mark the periods you wish to close under the Inventory Series. 

2. Make sure that you have posted all transactions for the period and year for all modules before 

closing fiscal periods. If you later need to post transactions to a fiscal period you have already 

closed, use the Fiscal Periods Setup window to reopen the period before posting the transaction.    

Inventory control year-end closing tips 

The year-end close must be completed prior to posting any transactions for the new year. 

Make sure to consider the implications outlined in this document by marking the following options in the 

Inventory Year-End Close window: Discontinued Items, Sold Receipts or Sold Lot Attributes.  If marked, 

all discontinued items, sold receipts or sold lot attributes that have a zero balance will be removed during 

the year-end closing process.  

If you mark Update Item's Standard Cost, the standard cost for any items that have been assigned the 

FIFO periodic or LIFO periodic valuation methods will be adjusted automatically to reflect each item's 

current cost, which is the amount you most recently paid for the item.  

There is no Year-End Closing report for Inventory. 
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Inventory year-end frequently asked questions 

Average cost update 

Q1.  How is the average cost of an item updated throughout the year and during the year-end 

closing process when using the average perpetual (weighted moving average) method of 

costing? 

If using the average perpetual costing method, all receipts for each item will be averaged to 

determine the average cost. Even if quantities are sold, the average does not change until another 

purchase receipt for the item is posted to the Inventory Purchase Receipts File. The year-end 

closing process does not change the average cost, but it will remove the purchase receipts that 

have been completely sold. The next time a receipt is entered, the average cost will be revalued 

with the receipts that remain in the Inventory Purchase Receipts File. 

Standard cost update 

Q2.  Can the Inventory Year-End Closing routine be used throughout the year to update the 

standard cost of items if using the periodic valuation method? 

This is not recommended because the beginning quantity field is updated during the year-end 

closing process. This would make that field incorrect on reports, such as the Turnover Report. 

There are two methods to adjust the standard cost of an item:  

1.  During the Inventory Year-End Close (recommended to only be done at year-end). From the 

Microsoft Dynamics GP menu, go to Tools > Routines > Inventory > Year-End Close. If you select 

to update the Standard Cost, the Standard Cost of the item will be adjusted automatically to the 

Current Cost or the amount you most recently paid for the item.  

2. You can edit the Standard Cost of the item in Item Maintenance on the item card.  Go to Item 

Maintenance (Cards > Inventory > Item)  

Discontinued items 

Q3.  When performing the Inventory Year-End Closing routine, I selected to Remove 

Discontinued Items; however, the discontinued items did not get removed. Why? 

If any of the discontinued items are components of kits, they will first need to be removed as 

components of the kits. You can use the Component Report (Reports > Inventory > Items > Kit List) 

to identify the components. To remove the item from the kit, use the Item Kit Maintenance Window, 

under Cards > Inventory > Kits. Select the kit item and find the discontinued item component. 

Highlight the item and choose Edit – Delete Row, to remove it as a component. Save the change 

you made. 
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Next, check if the items are finished goods or components of bills of materials (BM). The BM 

Component Where Used Report (Reports > Inventory > Setup > Component Where Used) can be 

used to identify which discontinued items are components of bills of materials. In the Report option, 

the following Bill Status checkboxes and Component Status checkboxes should be selected: Active, 

Pending, Obsolete. 

 

The BM Bill of Materials Report (Reports > Inventory > Setup > Single-Level Bill of Materials) can 

be used to find which discontinued items are bills of materials. In the report option, the following Bill 

Status checkboxes and Component Status checkboxes should be selected: Active, Pending, 

Obsolete. 

 

If any of the discontinued items are components of a bill of materials, the components need to be 

removed from the bills. This is true for all statuses of the bills and components, including Active, 

Pending and Obsolete. The components can be removed in the Bill of Materials Maintenance 

window (Cards > Inventory > Bill of Materials). In the Bill Number list, click the bill, click the status in 

the Status list and then find the component in the scrolling window. Click the component line, click 

Edit and then click Delete Row. Click Save to save the change. 

 

If any of the discontinued items are bills of materials, the bill needs to be deleted. This is true for all 

bill statuses, including Active, Pending and Obsolete. The bill can be deleted in the Bill of Materials 

Maintenance window (Cards > Inventory > Bill of Materials). In the Bill Number list, click the bill, 

click the status in the Status list and then click Delete. 
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Receivables Management year-end closing 
procedures (OPTIONAL) 

Receivables Management year-end closing checklist 

Note: Receivables Management is date-sensitive in certain areas. The Receivables Management closing 

process updates several tables and fields that track customer data. This is important for organizations 

that use any of the following items to track customer statistics:   

• The SmartList objects  

• The Receivables Management summary reports  

• The Amounts Since Last Close view in the Customer Summary window  

Therefore, to ensure the accuracy of the data displayed in the Customer SmartList objects, the 

Receivables Management summary reports and the Amounts Since Last Close view in the Customer 

Summary Inquiry window, we recommend that you follow these steps:  

1. Post all the sales and receivables transactions for the year  

2. Create a pre-year-end closing backup   

3. Close the year  

4. Close the fiscal periods (Optional)  

5. Close the tax year  

Detailed information for each step in the year-end checklist  

Step 1: Post all sales and receivables transactions for the year 

Post all the sales and receivables transactions for the year before you close the year. If you need to enter 

any transactions for a future period prior to closing the year, enter the transactions in a batch, but do not 

post it until after you have closed the year. 

As previously mentioned, since some areas of Microsoft Dynamics GP are date-sensitive, it is important 

to run the closing routine if you rely on any of the SmartLists, Receivables Summary Reports or the 

Amounts Since Last Close View of the Vendor Summary window to track your customer statistics. If you 

do not close the year after you enter all the transactions for the current year and before you enter all the 

transactions for the new year, these areas will contain incorrect information. The following areas of 

Microsoft Dynamics GP that are not date-sensitive are as follows: 

• The Amounts Since Last Close view in the Customer Summary window 

• The Customer Finance Charge Summary window 
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• The SmartList objects 

If the year-end routine was run after you have posted transactions to the new year, you can manually edit 

the information in the Amounts Since Last Close view in the Customer Summary window and in the 

Customer Finance Charge Summary window.  

To edit the Year to Date and Last Year fields in the Amounts Since Last Close view in the Customer 

Summary window, follow these steps: 

1. Go to Cards > Sales > Summary.  

2. In the Customer Summary window, type a customer ID in the Customer ID box.  

3. In the Summary View list, click Amounts Since Last Close.  

4. Manually update the fields in Year to Date and Last Year to the correct amounts and Save your 

changes. 

 
 

To edit the Year to Date and Last Year fields in the Customer Finance Charge Summary window, follow 

these steps: 

1. Go to Cards > Sales > Summary.  

2. In the Customer Summary window, type a customer ID in the Customer ID field.  

3. Click Finance Charges.  

4. Manually update the fields in Year to Date and Last Year to the correct amounts and Save your 

changes. 
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Depending on whether you run a fiscal year-end close or a calendar year-end close, different SmartList 

items are affected under the Customer SmartLists. The following list of SmartList columns are not date-

sensitive and are updated as a result of the Year-End Close: 

Note: The items that are flagged with an asterisk are affected by the calendar year-end close. All the 

other items are affected by the fiscal year-end close. 

• Average Days to Pay - Year  

• Finance Charges Calendar Year-to-Date (CYTD)*  

• Finance Charges Last Year Rate (LYR) Calendar*  

• High-Balance LYR  

• High-Balance YTD  

• Number of Average Days to Pay (ADTP) Documents - LYR  

• Number of ADTP Documents - Year  

• Number of Non-Sufficient Funds (NSF) Checks YTD  

• Total # Finance Charges (FC) LYR*  

• Total # FC YTD*  

• Total # Invoices LYR  

• Total # Invoices YTD  

• Total Amount of NSF Check YTD  

• Total Bad Debt LYR  

• Total Bad Debt YTD  

• Total Cash Received LYR  

• Total Cash Received YTD  

• Total Discounts Available YTD  
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• Total Discounts Taken LYR  

• Total Discounts Taken YTD  

• Total Finance Charges LYR*  

• Total Finance Charges YTD*  

• Total Returns LYR  

• Total Returns YTD  

• Total Sales LYR  

• Total Sales YTD  

• Total Waived FC LYR*  

• Total Waived FC YTD*  

• Total Write-Offs LYR  

• Total Write-Offs YTD  

• Unpaid Finance Charges YTD*  

• Write-Offs LYR  

• Write-Offs YTD  

Step 2: Create a pre-year-end closing backup 

Make a backup before you close the year. Place the backup in safe, permanent storage. This backup 

ensures that you have a permanent record of the company's financial position at the end of the year and 

allows you to quickly restore the information in the event a power fluctuation or some other problem 

occurs during the year-end close procedure. See the section on Backups under General Tips and 

Reminders for more information on creating backups.   

Step 3: Close the year 

1. Go to Microsoft Dynamics GP > Tools > Routines > Sales > Year-End Close.   

2. If you are closing both the fiscal year and the calendar year at the same time, click All.  

3. If you are closing only the calendar year, click Calendar. If you are closing only the fiscal year, 

click Fiscal.  

4. Click to select the Print Report checkbox, and then click Close Year. 
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Note: You cannot “Reprint” the Year-End Close report. We recommend that you select the checkbox 

to print the report and keep a hard copy of the year-end report together with the permanent year-end 

audit records.  

Calendar year details 

The calendar year-end process in Microsoft Dynamics GP clears the following fields in the Customer 

Summary window: 

• Finance Charges YTD  

• Total # FC YTD  

• Total Finance Charges YTD  

• Total Waived FC YTD  

• Unpaid Finance Charges YTD  

The calendar year-end process updates the amounts in the following fields: 

*Finance Charges LYR Calendar  

*Total # FC LYR  

Fiscal year details 

The fiscal year-end process in Microsoft Dynamics GP clears the following fields in the Customer 

Summary window: 

• Average Days to Pay (ADTP) - Year  

• High Balance YTD  

• Number of ADTP Documents - Year  

• Number of NSF Checks YTD  

• Total # Invoices YTD  

• Total Amount of NSF Check YTD  
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• Total Bad Debt YTD  

• Total Cash Received YTD  

• Total Discounts Available YTD  

• Total Discounts Taken YTD  

• Total Returns YTD  

• Total Sales YTD  

• Total Write-Offs YTD  

• Write-Offs YTD  

The fiscal year-end process updates the amounts in the following fields: 

• High Balance LYR  

• Number of ADTP Documents - LYR  

• Total # Invoices LYR  

• Total Bad Debt LYR  

• Total Cash Received LYR  

• Total Discounts Taken LYR  

• Total Returns LYR  

• Total Sales LYR  

• Total Write-Offs LYR  

• Write-Offs LYR  

Step 4: Close the fiscal periods (Optional) 

To ensure that no one posts transactions to an incorrect period or year, use the Fiscal Periods Setup 

window to close any fiscal periods that are still open for the year. 

Go to Microsoft Dynamics GP > Tools > Setup > Company > Fiscal Periods  

Make sure that you have posted all transactions for the period and year for all modules before closing 

fiscal periods. If you later need to post transactions to a fiscal period you have already closed, use the 

Fiscal Periods Setup window to reopen the period before posting the transaction. Mark the periods you 

wish to close under the Sales Series. 
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Step 5: Close the tax year (Optional) 

Note: Closing the tax year is only required if you use tax schedules and tax details and the related reports 

and SmartLists to track your organization’s Year to Date and Last Year’s Tax figures.   

Follow these steps only after you complete the year-end closing procedures for all the sales and 

purchasing modules. Do not close the tax year as part of the Receivables Management close if you are 

closing Payables Management at a later time. 

To close the tax year, follow these steps: 

1. Go to Microsoft Dynamics GP > Routines > Company > Tax Year-End Close. 

2. Click to select the Close Year checkbox and then click to select the Print Report checkbox.  

3. Click Process. 

 

Note: You cannot “Reprint” the Year-End Close report. We recommend that you select the checkbox to 

print the report and keep a hard copy of the year-end report together with the permanent year-end audit 

records.  

Note: If your organization assesses finance charges and prints customer statements, the year-to-date 

finance charges for December and January are not automatically printed on the statements. To add the 

year-to-date finance charges to the statements, follow these steps: 

December statements 

Go to Microsoft Dynamics GP > Tools > Customize > Report Writer   

1. In the Product list, click Microsoft Dynamics GP and then click OK.  

2. Click Reports.  

3. If you have not previously modified the statement form, click the statement form that you print in 

the Original Reports list, click Insert and then click the statement form in the Modified Reports list.  

4. If you have previously modified the statement form, click the statement form in the Modified 

Reports list.  

5. Click Open 

6. In the Report Definition window, click Tables.  
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7. In the Report Table Relationships window, click RM Customer MSTR and then click New.  

8. In the Related Tables window, click Customer Master Summary, and then click OK.  

9. Click Close  

10. Click Layout  

11. In the resource list in the Toolbox box, click Customer Master Summary.  

12. In the field list, drag Finance Charges CYTD to the layout of the report. You can position this field 

in any section of the report.  

13. On the File menu, click Microsoft Dynamics GP. When you are prompted to save the changes, 

click Save.  

14. If you have not previously modified this report, you must grant security to the report. To grant 

security to the report: 

• Go to Microsoft Dynamics GP > Tools > Setup > System > Alternate/Modified Forms and 

Reports. In the ID box, enter the user ID.  

• In the Product list, click Microsoft Dynamics GP.   

• In the Type list, click Reports.  

• Expand Sales and then expand the node of the modified form.  

• Click Microsoft Dynamics GP (Modified).  

January statements 

• Follow steps 1 through 11 in the December statements section.  

• In the field list, drag Finance Charges LYR Calendar to the layout of the report. You can position 

this field in any section of the report.  

• Follow steps 13 and 14 in the December statements section.  

Receivables management year-end closing tips 

It is not necessary to close the calendar and fiscal years before entering transactions for the new year. 

The system will automatically post to the correct fiscal and calendar years, according to the dates of the 

transactions. However, as previously mentioned, there are certain areas of the program that are not date-

sensitive, including Customer SmartList objects, Receivables Summary reports and the Amounts since 

Last Close view in the Receivables Summary window. Information in these windows and reports will not 

be correct if you post transactions to the new year before closing the year. 

Closing the calendar year will clear the calendar year-to-date (YTD) finance charges and move them to 

the Last Year field on the customer records. 
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The calendar year-end close in Receivables will take place at the end of the calendar year, regardless of 

when your fiscal year-ends. If your calendar year coincides with the fiscal year, then you will close both at 

the end of the calendar year. 

The YTD finance charges do not automatically print on the statements in December and January. If you 

want them to print on the statements, you must modify them by following the procedures outlined in this 

document. These procedures are different for each month.
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Payables Management year-end closing procedures 
(Optional) 

Note:  Payables Management is date-sensitive in certain areas. The Payables Management closing 

process updates several tables and fields that track vendor data. This is important for organizations that 

use any of the following items to track vendor statistics:   

• The SmartList objects  

• The Payables Management summary reports  

• The Amounts Since Last Close view in the Vendor Summary window  

Therefore, to ensure the accuracy of the data displayed in the Vendor SmartList objects, the Payables 

Management summary reports and the Amounts Since Last Close view in the Vendor Summary Inquiry 

window, we recommend that you follow these steps:  

Note: Use this checklist if you are closing your fiscal year and your calendar year at the same time.   

Note:  The IRS has made changes to the 1099 NEC, MISC, and DIV forms.  You must install the 2022 

Year End Update to print the new forms.  If upgrading your Dynamics GP is not an option, please contact 

your RSM representative for alternative options.  See link below to download the update and instructions: 

Microsoft Dynamics GP US Year End Update 2022 

1. Post all transactions for the year.  

2. Print the Historical Aged Trial Balance report.  

3. Print the Vendor Period Analysis Report.  

4. Make a backup that is named "Pre-1099 Edits."  

5. Verify the 1099 information and edit as required.  

6. Print the 1099 statements.  

7. Make a backup that is named "Pre-Year-End."  

8. Close the year.  

9. Close the fiscal periods.  

10. Close the tax year.  

Payables Management calendar year-end closing checklist 

1. Post all transactions for the calendar year.  

2. Print the Historical Aged Trial Balance report.  

3. Make a backup that is named "Pre-1099 Edits."  

https://docs.microsoft.com/en-us/dynamics/s-e/gp/usgpye2018_396
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4. Verify the 1099 information and edit it, if it is required.  

5. Print the 1099 statements.  

6. Make a backup that is named "Pre-Year-End."  

7. Close the calendar year.  

8. Close the fiscal periods.  

9. Close the tax year.  

Payables Management fiscal year-end closing checklist 

1. Post all transactions for the fiscal year. 

2. Print the Vendor Period Analysis Report.  

3. Make a backup that is named "Pre-Year-End."  

4. Close the fiscal year.  

5. Close the fiscal periods.  

Detailed information for each step in the year-end Master checklist  

Step 1: Post all transactions for the year 

Post all the payables and purchasing transactions for the year before you close the year. If you need to 

enter any transactions for a future period prior to closing the year, enter the transactions in a batch, but 

do not post them until after you have closed the year. 

As previously mentioned, since some areas of Microsoft Dynamics GP are not date-sensitive, it is 

important to run the closing routine if you rely on any of the SmartLists, Payables Summary Reports or 

the Amounts Since Last Close View of the Vendor Summary window to track your vendor statistics. If you 

do not close the year after you enter all the transactions for the current year, and before you enter any 

transactions for the new year, these areas will contain incorrect information. The following areas of 

Microsoft Dynamics GP that are not date-sensitive are as follows: 

• The Amounts Since Last Close view in the Vendor Summary window 

• The SmartList Objects 

• Vendor Summary Reports 

If the Year-End routine was run after you have posted transactions to the new year, you can manually edit 

the information in the Amounts Since Last Close view in the Vendor Summary window. 

To Edit the Year to Date and Last Year fields in the Amounts Since Last Close view in the Customer 

Summary window, follow these steps: 

1. Go to Cards > Purchasing > Summary.  
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2. In the Vendor Credit Summary window, type a vendor ID in the Vendor ID field and then click 

Yearly.  

3. In the Summary View list, click Amounts Since Last Close.  

4. Manually update the fields in Year to Date and Last Year to the correct amounts and click OK to 

save your changes. 

 

Different SmartList items are affected under the Vendor SmartLists, depending on whether you run a 

Fiscal Year-End Close or a Calendar Year-End close. The following list of SmartList columns are not 

date-sensitive and are updated as a result of the Year-End Close: 

Note: The items flagged with an asterisk are affected by the calendar year-end close. All other items are 

affected by the fiscal year-end close. 

• 1099 Amount YTD* 

• 1099 Amount LYR*  

• Amount Billed YTD  

• Amount Billed LYR  

• Amount Paid YTD  

• Amount Paid LYR  

• Average Days To Pay - Year  

• Discount Available LYR  

• Discount Available YTD  

• Discount Lost LYR  

• Discount Lost YTD  

• Discount Taken LYR  
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• Discount Taken YTD  

• Finance Charge LYR   

• Finance Charge YTD   

• Number of Finance Charges LYR  

• Number of Finance Charges YTD  

• Number of Invoice LYR  

• Number of Invoice YTD  

• Number of Paid Invoice YTD  

• Returns LYR  

• Returns YTD  

• Trade Discounts Taken LYR  

• Trade Discounts Taken YTD  

• Withholding LYR  

• Withholding YTD  

• Write-Offs LYR  

• Write-Offs YTD  

To view the Vendor Summary reports, follow these steps: 

• Go to Reports > Purchasing> Analysis   

• In the Reports list, click Calendar Year.  

• In the Options list, click an option and then click Print.  

Step 2: Print the Historical Aged Trial Balance report 

We recommend that you print a hard copy of the Historical Aged Trial Balance report to keep with your 

year-end permanent financial records. To do this, follow these steps: 

1. Go to Reports > Purchasing > Trial Balance. 

2. In the Reports list, click Historical Aged Trial Balance.  

Step 3: Print the Vendor Period Analysis report 

We recommend that you print a hard copy of the Vendor Period Analysis report to keep with your year-

end permanent financial records. To do this, follow these steps: 
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1. Go to Reports > Purchasing > Analysis. 

2. In the Reports list, click Period.  

 

Step 4: Make a backup that is named "Pre-1099 Edits" 

Make a backup before you close the year. Place the backup in safe, permanent storage. This backup 

ensures that you have a permanent record of the company's financial position at the end of the year and 

allows you to quickly restore the information in the event a power fluctuation or some other problem 

occurs during the year-end close procedure. See the section on Backups under General Tips and 

Reminders for more information on creating backups. 

Step 5: Verify the 1099 Information and edit as required 

To print the 1099 edit list, follow these steps: 

Go to Microsoft Dynamics GP > Tools > Routines > Purchasing > Print 1099. On the file menu, click Print. 

 

If you need to edit any 1099 information, use one of the following methods (Method 1 and 2 are 

recommended for Microsoft Dynamics GP 2013 and later versions.) 

 

 

Method 1: Edit 1099 Transaction details (Applies to Microsoft Dynamics GP 2013 and later versions) 

1. Go to Transactions > Purchasing > Edit 1099 Transaction Information. 

2. Enter the Vendor ID. 

3. Select to filter on a range for particular vouchers, document numbers or document date. 

4. Make changes in the scrolling window to any of the following fields: Tax Type, Box Number or 

1099 Amount. 
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5. Click Process and Print the Report. 

  

 

Method 2: VENDOR NOT MARKED CORRECTLY: (Applies to Microsoft Dynamics GP 2013 and later 

versions) If you marked a vendor as a 1099 type and should not have, or if you did not mark a vendor as 

1099 type that should have been, use the Update 1099 Information utility to change the 1099 status on 

the vendor and/or to update the 1099 information.  

 

1. From the Microsoft Dynamics GP drop down menu, go to Utilities > Purchasing > Update 1099 

Information. 

 

2. Mark the bullet for Vendor and 1099 Transactions.  

 

3. In the FROM and TO sections enter the following: 

 

• To change a vendor to be a 1099 type, select Not a 1099 Vendor in the FROM section, and select the 

appropriate 1099 type of Dividend, Interest, Miscellaneous, or Nonemployee Compensation and the 

appropriate 1099 Box number in the TO section. (for the 2022 calendar year forward, Nonemployee 

Compensation and Box 1 is the most common.) 

 

• To change a vendor to NOT be a 1099 type, select the current Tax Type and 1099 Box Number that is 

selected on the Vendor Maintenance Options window for the vendor in the FROM section, and select Not 

a 1099 Vendor in the TO section. 
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*If  the Not a 1099 Vendor option does not appear in the drop-down list, then you are either on version 

prior to Microsoft Dynamics GP 2013, or you did not select Vendor and 1099 Transactions as instructed 

in step 2.  

 

4. Use the Range restriction to restrict to the Vendor ID that you wish to change and click INSERT. 

 

5. Click Process. The vendor status will be updated on the Vendor Maintenance Options window, and the 

1099 information will be updated appropriately. You can use the 1099 details window (see Method 1) to 

verify.  

 

 

Method 3: Edit the 1099 directly (Use for Microsoft Dynamics GP 2010 and prior versions, but can work 

for all versions) (Note: The Reconcile utility for 1099 amounts would undo any edits you make using this 

method.) 

1. Go to Cards > Purchasing > 1099 Details.  

2. In the Vendor ID list, enter a vendor ID.   

3. In the Tax Type list, select one of the following:  

• Dividend  

• Interest  

• Miscellaneous  

• Nonemployee Compensation 

4. In the Display area, click Month, select a Month and then type in the appropriate year. 

5. In the Amount column, type the correct 1099 amount.  

6. Click Save.   

Note: You must edit 1099 details while in a specific month. You cannot edit the 1099 details while in the 

Year display. 
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Method 4: Edit the 1099 directly (Use for Microsoft Dynamics GP 2010 and prior versions but will work for 

all versions) (Note: The Reconcile utility for 1099 Amounts would undo any edits you make using this 

method.)  

 

To edit the 1099 information for a vendor, follow these steps: 

1. Go to Cards > Purchasing > Summary.  

2. In the Vendor ID field, type in the Vendor ID and then click Period.  

3. In the Year field, type in the appropriate year. 

4. In the Month/Period field, type the number of the period that you must edit.  

5. Click the "1099 Details" blue expansion button that appears next to the 1099 Amount field. This 

1099 Details window will open.  

6. In the Amount column, type the correct 1099 amount for the respective box. 

7. Press Save. Exit out of the remaining windows. 
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Step 6: Print the 1099 Statements 

Note: You can print 1099 statements at any time. 

1. To print the 1099 statements: Go to Microsoft Dynamics GP > Tools > Routines > Purchasing > Print 

1099. 

2. In the 1099 Year field, type in the appropriate year.  

Each of your 1099 report types must be printed separately. In the Print 1099 window, click the option that 

you want in the 1099 Type and Form Type fields and then click Print. 

.  

Special notes for Microsoft Dynamics GP 1099 Details: 

In Microsoft Dynamics GP, when a different 1099 Box Number needs to be flagged on the 1099, the 

information from the 1099 Details for each vendor is used to determine the amounts that print on each 

1099 form and in each box on the 1099 form.  

If the vendor has an amount in the 1099 Details window, that amount will be reported on the 1099 Form in 

the appropriate form and box, based on the minimum amounts entered for each box in the Payables 

Setup Window: Microsoft Dynamics GP > Tools > Setup > Purchasing > Payables > 1099 Setup.  
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The following table provides additional information about the fields on the 1099 form and where this 

information can be located in Microsoft Dynamics GP. 

Field Window 

Payer’s name, street address, city, state and ZIP or 
postal code 

Print 1099 window 

DBA (new field) DBA field in the Vendor Maintenance Options 
window 

Payer’s federal identification number Print 1099 window 

Recipient’s name, address and ZIP or postal code 1099 address of the Vendor Maintenance window 

Recipient’s identification number Tax ID field of the Vendor Maintenance Options 
window 

Amounts for boxes 1-9 on the Dividend Form, 1-16 on 
the Miscellaneous Form, or 1,4,5,7 on the Nonemployee 
Compensation Form 

1099 Amount field in the Vendor Yearly Summary 
window 

Note: Currently, Microsoft Dynamics GP does not handle magnetic media filing of state 1099s. If you 

need to process electronic 1099 filing, please contact your RSM client representative. 

Step 7: Make a backup that is named "Pre-Year-End" 

Make a backup before you close the year. Place the backup in safe, permanent storage. This backup 

ensures that you have a permanent record of the company's financial position at the end of the year and 

allows you to quickly restore the information in the event a power fluctuation or some other problem 

occurs during the year-end close procedure. See the section on Backups under General Tips and 

Reminders for more information on creating backups. 

Step 8: Close the year 

1. To close the year, go to Microsoft Dynamics GP > Tools > Routines > Purchasing > Year-End Close. 

2. If you are closing both your fiscal and calendar year at the same time, click All. 

3. If you are just closing your calendar year, click Calendar. If you are just closing your fiscal year, click 

Fiscal.  

4. Click to select the Print Report checkbox and then click Close Year. 
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Note: You cannot “Reprint” the Year-End Close report. We recommend that you select the checkbox to 

print the report and keep a hard copy or PDF of the year-end report together with the permanent year-end 

audit records. 

Once you have completed the Year-End Close, you can view the Vendor Yearly Summary window to see 

how the 1099 amount fields have been updated. To view the Vendor Yearly Summary, follow these steps: 

1. Go to Cards > Purchasing > Summary. 

2. In the Vendor ID field, type a vendor ID and then click Yearly.   

The calendar year-end process in Microsoft Dynamics GP will clear the 1099 Amount Year to Date field 

and then transfer the amount to the 1099 Amount Last Year field for the Amounts Since Last Close view 

of the Vendor Yearly Summary window. 

The Amounts Since Last Close View: 
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The fiscal year-end process in Microsoft Dynamics GP will clear the following fields: 

• Amount Billed YTD  

• Amount Paid YTD  

• Average Days To Pay - Year  

• Discount Available YTD  

• Discount Lost YTD  

• Discount Taken YTD  

• Finance Charge YTD   

• Number of Finance Charges YTD  

• Number of Invoice YTD  

• Number of Paid Invoice YTD  

• Returns YTD  

• Trade Discounts Taken YTD  

• Withholding YTD  

• Write-Offs YTD  

The amounts in these fields will also be updated in the Amounts Since Last Close view of the Vendor 

Yearly Summary window: 

• Amount Billed LYR  

• Amount Paid LYR  

• Discount Available LYR  

• Discount Lost LYR  

• Discount Taken LYR  

• Finance Charge LYR   

• Number of Finance Charges LYR  

• Number of Invoice LYR  

• Returns LYR  

• Trade Discounts Taken LYR  

• Withholding LYR  

• Write-Offs LYR  

Step 9: Close the Fiscal Periods 

To ensure that no one posts transactions to an incorrect period or year, use the Fiscal Periods Setup 

window to close any fiscal periods that are still open for the year. 

Go to Microsoft Dynamics GP > Tools > Setup > Company > Fiscal Periods. 

Make sure that you have posted all transactions for the period and year for all modules before closing 

fiscal periods. If you later need to post transactions to a fiscal period you have already closed, use the 

Fiscal Periods Setup window to reopen the period before posting the transaction. Mark the periods you 

wish to close under the Purchasing Series. 
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Step 10: Close the tax year 

Note: Closing the tax year is only required if you use tax schedules and tax details and the related reports 

and SmartLists to track your organization’s Year to Date and Last Year’s tax figures.   

Follow these steps only after you complete the year-end closing procedures for all the sales and 

purchasing modules. Do not close the tax year as part of the Payables Management close if you are 

closing Receivables Management at a later time. 

1. To close the tax year, go to Microsoft Dynamics GP > Routines >  Company > Tax Year-End 

Close. 

2. Click to select the Close Year checkbox and the Print Report checkbox.  

3. Click Process.  

4. Click Yes when you are prompted to continue with the year-end close. 

 

Note: You cannot “Reprint” the Year-End Close report. We recommend that you select the checkbox to 

print the report and keep a hard copy of the year-end report together with the permanent year-end audit 

records.  

Payables Management frequently asked questions 

Q1.  Are inactive vendor records cleared during year-end closing? If not, how can inactive vendor 

records be removed?  

No, inactive vendor records are not automatically removed. To remove an inactive vendor record, the 

following conditions must be true: 

• No current-year 1099 amounts exist for the vendor  

• The vendor has no documents in Work or History  

To delete all inactive vendor records that fit these criteria, go to Microsoft Dynamics GP > Tools > 

Utilities > Purchasing > Mass Vendor Delete. 

In the Range list, click by Vendor Status. In the From list, click Inactive. In the To list, click 

Inactive. Click Process.  
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Q2.  What should I do if I must issue a check in the new year, but I am not ready to close the old 

year yet? 

Print the checks, but post them after you process your year-end closing. If you must post the checks 

immediately, you can edit the Amount Paid fields in the Amounts Since Last Close view of the Vendor 

Yearly Summary window. 

Q3.  What exactly does the Payables Management Year-End Close procedure do? 

The Calendar Year-End Close moves the 1099 Amount YTD into 1099 Last Year in the Vendor 

Yearly Summary window. The Fiscal Year-End Close moves all other YTD amounts into Last Year 

amounts. 

Q4.   When viewing information in the Vendor Yearly Summary window, I discovered that I have 

the incorrect amount in the 1099 row for Year-to-Date Amount. How can I fix this, so my 1099 

forms will print the correct amount? 

Identify what the correct amount should be for the calendar year's 1099 report. In Microsoft 

Dynamics GP: Go to Cards > Purchasing > Vendor Period Summary and enter the correct 

amount(s). In the Yearly Summary window, choose Calendar Year for the view, and click the 

Calculate button. The correct 1099 Year to Date amount will now appear. After the calendar year-

end close for Payables Management is completed, the amount will be moved to the Last Year 

column for 1099 amounts. 

 

Example: Company ABC was paid $1,000 in 1099 reportable amounts for the year ended Dec. 31, 

2022. It is now Jan. 20, 2023, and in the Vendor Yearly Summary window, the 1099 amount is 

$1,150. The calendar-year close has not yet taken place, and 1099s have not been printed. 

 

Open the Vendor Period Summary window and choose the appropriate calendar year and month. 

Enter the correct 1099 amounts. When you go to the Vendor Yearly Summary window, you can click 

the Calculate button to see the results of your changes in the Year-to-Date column. 

 

In Microsoft Dynamics GP 10.0 and GP 2010: Go to Cards > Purchasing > 1099 Details window and 

enter the correct amount(s) in the correct box(es) for the appropriate 1099 tax type(s) in the 

appropriate period(s). Display by Year to view the totals in each box for the calendar year. 

In Microsoft Dynamics GP 2013 and later versions: Go to Transactions > Purchasing > Edit 1099 

Transaction Information.  Enter the correct amount(s), the correct box(es) and the correct 1099 types. 

Q5.  Is there a way to print an edit list of the 1099 vendors before I actually print the 1099 

statements? 
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In Microsoft Dynamics GP, a 1099 report can be printed using the Print 1099 window: (Tools > 

Routines > Purchasing > Print 1099). When the Print 1099 window is open, choose Print from the File 

menu. An edit list that contains the Vendor ID, Vendor Name, Address and 1099 amount will be 

printed.  

Q6.  I've printed 1099 statements and some of the statements didn't have the vendor name 

appearing on them. What should I do?  

When printing 1099 statements, the Check Name field entered for the vendor record in the Vendor 

Maintenance window will appear on the statement. If there isn't a vendor name appearing on the 

statement, the Check Name field in this window is blank. Enter a Check Name for each vendor or 

use the Report Writer to change the report to use a different field.  

Q7.  I can’t make 1099 forms align correctly. What can I do? 

Try the following method to correct alignment issues: 

1. Print the 1099s to screen. 

2. Choose the printer icon button on the top left. 

3. A print dialogue box with horizontal and vertical alignments will appear on the right. Adjust 

according to the situations below: 

 
Problem Adjustment 

Form prints too high Enter a positive vertical adjustment (.25 is one line) 

Form prints too low Enter a negative vertical adjustment (-.25 is one line) 

Form prints too far right Enter a negative horizontal adjustment 

Form prints too far left Enter a positive horizontal adjustment 

Payables Management year-end closing tips 

Microsoft Dynamics GP 2013 and later versions offer NEW FUNCTIONALITY involving 1099s: 

• Separate 1099 Address ID field on vendor card 

• Additional box numbers added for each Tax Type 

• Additional fields on the 1099 Details window 

• New functionality to edit 1099 information: 

– Edit 1099 Transaction Information window (per transaction) 

– Update 1099 Information utility now has options for “Not a 1099 vendor” tax type (per vendor) 

• Ability to print 1096 Summary Form 
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You can print the 1099 statements using the Print 1099 window any time and for any calendar year.   

You can enter the Payer’s federal ID number in the Company Setup window: Microsoft Dynamics GP > 

Tools > Setup > Company > Company, so that it defaults to the Print 1099 window.
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Payroll Year-End Update and closing procedures 

The U.S. 2022 Year-end Update contains software changes to allow you to comply with 2023 filing 

requirements as well as the most recent fixes for Microsoft Dynamics GP and other quality report fixes 

related to the payroll year-end.  

In addition to the Payroll Year-End closing checklist, the following information also includes tips on 

installing the tax updates, preparation tasks and instructions on reviewing your W-2 forms prior to year-

end.   

Latest runtime and Service Pack version numbers 

The Year-End Update for Dynamics GP18.5 includes all prior service packs, hot fixes.  

The Year-End Update and any additional Tax Updates are no longer available for versions prior to GP 

18.3.  Customers on GP 18.2 and prior will need to upgrade their system to receive Payroll fixes and tax 

updates. 

Update files and documentation can be downloaded from the link below: 

Microsoft Dynamics US Year End Update 2022 

For more information on Year-End, visit the Microsoft Dynamics Year-End Blog Series for 2022 for 

everything Year-End. See link below: 

 
Microsoft Dynamics GP - 2022 Year-End Blog Series 

 
The blog is evolving and will contain posts on year-end issues for each series.  
   
After you install the Year-End Update, check the Last Year-End Update date. Go to Tools > Setup > 

Payroll > Payroll. The date should be 11/18/2022.  

Payroll Year End Changes 

No change to W-2, W-3, W-4 Forms 

Regulatory changes to 1099-R Forms 

No change to EFW2 

 

 

https://docs.microsoft.com/en-us/dynamics/s-e/gp/usgpye2018_396
https://community.dynamics.com/gp/b/dynamicsgp/posts/microsoft-dynamics-gp---2021-year-end-blog-series-schedule
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Changes to federal tax filing and to W-2 electronic filing  

Validating your W-2 information has not changed for the 2023 tax year. Testing may be performed online. 
Use the following link to access a site where you can test and validate your W-2 wage information: 
 
https://www.ssa.gov/bso/bsowelcome.htm 

Deadline for 2023 filing to SSA is 2/1/2023. 

Beginning in 2022, if you send 100 or more W-2’s, you must send them electronically 

Note:  In 2022, that limit was lowered to 10. 

Year-end blog series 

Microsoft Dynamics GP support engineers maintain a blog that contains posts related to year-end 

processing. Refer to the link below for new or updated information related to year- end processes: 

https://community.dynamics.com/members/terry-r-heley/blogs 

The targeted release dates for the 2023 U.S. Payroll Tax Updates: 

• 2023 Round 1 – December 27,2022 

• 2023 Round 2 – Mid January 2023 

Make sure that you have restorable backups of the company database, the Microsoft Dynamics GP 

Dynamics application code folder and all Reports and Forms dictionaries prior to installing the Year-End 

Update and the Tax Table Updates referenced in this document. 

During the installation process, do not allow users to work in Microsoft Dynamics GP until the 2022 

Payroll Year-End update is installed on ALL workstations. The update can change the code and the 

reports dictionary, and all users need to be on the same version before accessing Microsoft Dynamics 

GP.   

Note: If you have any third-party applications or specific modifications to your Microsoft Dynamics GP 

system, please consult with your local RSM representative or the support desk prior to applying any 

service packs. 

Other preparation tasks for Year-End 

Verify that you have the appropriate W-2 checkboxes marked per employee in Cards > Payroll > Tax. 

The Retirement Plan box has to be checked manually; it does not get marked automatically when an 

employee has an active retirement plan deduction. 

Verify that the state withholding information has been entered in: Tools > Setup > Payroll > Tax ID. The 

Employer ID Number entered here will print on the W-2s. 

https://www.ssa.gov/bso/bsowelcome.htm
https://community.dynamics.com/members/terry-r-heley/blogs
https://community.dynamics.com/members/terry-r-heley/blogs
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Verify that your deductions and benefits have been set up with the proper W-2 box and label information. 

For instance, 401(k) deductions should be displayed in Box 12 with a label “D.” 

All noncash taxable benefits, such as automobile expenses, life insurance benefits, moving expenses, 

etc., should be included in the final pay run of the calendar year. The appropriate taxes need to be 

calculated on the benefit and taken out of regular pay. 

Verify that you have installed a 2023 Payroll tax update.  Go to Microsoft Dynamics GP > Tools > Setup > 

System > Payroll Tax. The first tax update for the year should be 12/22/2023 or a later date is fine.  To 

install the latest tax update, go to Microsoft Dynamics GP >Tools > Maintenance > U.S. Payroll Updates 

> Check for Tax Updates. 

Testing W-2s before closing the year 

It is possible to review W-2 information without officially closing the year. These steps should only be done 

when a pay run is not in process: 

1. Make a backup.  

2. Go to Tools > Routines > Payroll > Year-End Closing.  

3. Mark the Create Year-End Wage File and click on Process.  

4. You may now review W-2 information as needed under: Tools > Routines > Payroll > Edit W-2s.  

5. When completed, go back to: Tools > Routines > Payroll > Year-End Closing, and mark the 

Create Year-End Wage File again and click on Process, making sure you have the current year 

entered.  

6. A message will appear saying that “The file already exists, would you like to delete it?” Click 

Delete.  

7. When prompted to Recreate the files, click Cancel. You do not want to click the Create button at 

this point. You must delete the Year-End Wage file by going through this process, or you will not 

be able to process any payroll. 

Payroll Year-End checklists 

Depending on your organization’s Payroll Year-End requirements, the following checklists are provided, 

followed by the detailed steps for each scenario: 

• Printing 2022 Statements Before Processing 2023 Pay Runs 

• Processing 2023 Pay Runs Before Printing 2022 Statements 
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Printing 2022 Statements Before Processing 2023 Pay Runs 

1. Verify that you have installed a 2022 Payroll tax update.  Go to Microsoft Dynamics GP > Tools > 

Setup > System > Payroll Tax. The first tax update for the year should be 12/16/2021 or a later 

date is fine.  Complete all pay runs for the current year.  

2. Complete all monthly and quarterly payroll period-end procedures for the current year. (Optional) 

3. Make a backup of the company database labeled “Pre Year-End Wage File.” 

4. Install the Year-End Update.  

5. Create the Year-End Wage file.  

6. Make a backup of your company database labeled “Post Year-End Wage File.” 

7. Verify W-2 and 1099-R statement information.  

8. Print the W-2 and 1099 Validation Reports, W-2 and 1099-R Statements and W-3 and 1096 

Forms. 

9. Prepare and submit W-2 information in the federal EFW2 format, if required. 

10. Archive inactive employee human resources information. (Optional) 

11. Create the human resources attendance period schedules for the new year. 

12. Set up fiscal periods for 2023. 

13. Delete human resources information for inactive employees. (Optional) 

14. Close the fiscal periods for the Payroll series for 2022. (Optional) 

15. Install the Payroll Tax Update Round 1 for 2023.  

Detailed steps for Printing 2022 Statements Before Processing 2023 Pay Runs 

Step 1: Verify the version of Microsoft Dynamics GP and the latest Payroll Tax Updates currently 

installed. 

The 2022 Payroll Year-End Update and the 2023 Payroll Tax Updates will be available for the 
currently installed versions: 

• Microsoft Dynamics GP 18.4.xxxx – Year End Changes included with latest release 

To verify your version information, log in to Microsoft Dynamics GP. On the home page, click on: (?) 

Button > About Microsoft Dynamics GP.  

To verify the latest 2022 Payroll tax update currently installed, go to: Tools > Setup > System > Payroll 

Tax.  

Step 2: Complete all pay runs for the current year  
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It is important that you complete all pay runs for 2022 before you install the 2023 Payroll Tax Update 

Round 1. If you install the 2023 Payroll Tax Update prior to completing your 2022 pay runs, taxes will be 

calculated at 2023 rates for the remainder of the 2022 pay runs. In addition, if the 2023 tax update is 

installed prior to creating the Year-End Wage file, your W-2s will report incorrect information. 

Step 3: Complete all Payroll month and quarter-end procedures (Optional) 

For more information about period-end procedures for payroll, view Chapter 21, "Payroll Company 

Routines," in the Microsoft Dynamics GP user's manual. 

Step 4: Make a backup of the company database and label it “Pre Year-End Wage File” 

Make a backup before you close the year. Place the backup in safe, permanent storage. This backup 

ensures that you have a permanent record of the company's financial position at the end of the year and 

allows you to quickly restore the information in the event a power fluctuation or some other problem 

occurs during the year-end close procedure. See the section on Backups under General Tips and 

Reminders for more information on creating backups.   

Note:  It is highly recommended that you back up the files Reports.dic, Forms.dic and Dynamics.vba in 

your application before installing the U.S. 2022 Year-End Update. 

Step 5: Install the Year-End update 

To install the payroll year-end update, follow the installation instructions provided with the update. The 

update must be installed on the server and each computer that has Microsoft Dynamics GP installed. Do 

not restart Microsoft Dynamics GP on any workstation until the update has been installed on all 

workstations that run Microsoft Dynamics GP. 

Step 6: Create the Year-End file 

 

Go to Microsoft Dynamics GP > Tools > Routines > Payroll > Year-end Closing. In the Year field, type 

2022 and then click Process.  

Note: You can install the payroll tax update for 2023 any time after the Year-end file for 2022 has been 

created. 

Step 7: Make a backup of the new file of the company database and label it “Post Year-End Wage 

File”  

Make a backup and then put this backup into safe, permanent storage. By creating a backup, you make 

sure that you have a permanent record of the company's financial position at the end of the year. You can 
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restore the backup to quickly recover data if a power fluctuation or other problem occurs during the year-

end closing procedure. 

Step 8: Verify W-2 and 1099-R statement information 

 

To view W-2 information in Microsoft Dynamics GP, go to: Microsoft Dynamics GP > Tools > Routines > 

Payroll > Edit W-2s. 

To view the 1099-R information in Microsoft Dynamics GP, go to: Microsoft Dynamics GP > Tools > 

Routines > Payroll > Edit 1099-Rs. 

Note: If you change the W-2 or the 1099-R information, we recommend that you make another backup. 

Step 9: Print the W-2 Validation Reports, W-2 Statements and W-3 Transmittal Form 

1. Go to Microsoft Dynamics GP > Tools > Routines > Payroll > Print W-2s. 

2. Select the option to Print the Validation Report. 

The report displays warnings if there are employee record errors, except for employees with no wages, 

tips or withholding information entered on their W-2 form. W-2 forms will not be printed for employees with 

no earnings or withholding information.   
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If you see errors on the Validation Report, you will need to REMOVE the Year-End information before 

making changes. Make corrections as needed and then create the Year-End Wage file again.     

To remove the Year-End Wage file, go to: Microsoft Dynamics GP > Tools > Utilities > Payroll > Remove 

Year-End Information. 

 

Select the year, Insert and Click Process. 

Note: The W-2 Validation Report will include all employees that exist within the Microsoft Dynamics GP 

database; however, only those with wages will actually print to the W-2 form. For more information about 

validation report warnings, please refer to the Knowledge Base article number 872100 in the link below: 

https://support.microsoft.com/en-us/kb/872100 

To print the W-2 statements, in the Print W-2 Forms window, specify the following settings: 

1. Print W-2s for: Normal Year-End  

2. Print: W-2 Forms  

3. Click Print  

Note: You can print employee W-2 statements as many times as needed. 

 

https://support.microsoft.com/en-us/kb/872100
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To print the W-3 Transmittal Form, select the option to print the W-3 Transmittal Form and click Print.  

Note: You can print the W-3 Transmittal Form as many times as needed. 

To view 1099-Rs, you will also print the 1099-R Validation Report. 

1. Go to Microsoft Dynamics GP > Tools > Routines > Payroll > Print 1099-Rs. 

2. Select the option to Print the Validation Report. 

 

 If you see errors on the Validation Report, you will need to REMOVE the Year-End information before 

making changes. Make corrections as needed and then create the Year-End Wage file again.     

To remove the Year-End Wage file, go to: Microsoft Dynamics GP > Tools > Utilities > Payroll > Remove 

Year-End Information. 

If you make changes to your 1099-R records or W-2 records, we recommend that you make another 

backup.  

Note: W-2s and 1099-Rs can be printed any time after the data has been validated. 

To print the 1099 forms, in the 1099-R Forms window, select the year, click 1099-R Forms and click Print.  

Note: You can print employee 1099-R forms as many times as needed. 

To print the 1096 Transmittal form in the Print 1099-R Forms window, select the year, click 1096 

Transmittal Form and click Print.  

Note: You can print the 1096 Transmittal form as many times as needed. 

Step 10: Prepare and submit W-2 information in the federal EFW2 Format, if required 

If you plan to submit W2s electronically, the U.S. W-2 Magnetic Media feature must be registered for 

Microsoft Dynamics GP. To verify this, choose Help >> About Microsoft Dynamics GP and choose 
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Options. Scroll through the list of registered modules to find U.S. W-2 Magnetic Media. A check mark 

indicates it is registered. You will then need to register for a User Identification Number (UIN) with the 

Social Security Administration. You only need to register once for a UIN. After you’ve obtained your UIN, 

you may use it indefinitely, provided you change your password once a year.  

To obtain a UIN and find more information about the electronics submission formats and free accuracy 

checking, visit the link below: 

www.socialsecurity.gov/bso/bsowelcome.htm 

Microsoft Dynamics GP currently supports filing magnetic media for federal W-2 information in Magnetic 

Media Reporting and Electronic Filing (MMREF-1) format. Some states also accept this format. 

Magnetic media filing of 1099-Rs, state W-2s, State Unemployment Tax Act (SUTA) or formats other than 

MMREF-1 are not supported. You will need to use separate software or services for filing these items. 

Contact your local RSM representative or the support desk for more information on obtaining compatible 

magnetic media products. 

To create a magnetic media file, go to: Microsoft Dynamics GP > Routines > Payroll > W-2 Magnetic 

Media. 

 

1. In the Magnetic Media window, click to select the checkbox that is next to each company that you 

want to include in your magnetic media file.  

2. In the User ID Number field, enter the User ID Number.  

3. Click Submitter; the Magnetic Media Submitter Information window opens.  

4. Enter the authorized submission information.  

5. Close the Magnetic Media Submitter Information window.  

6. Change the file destination information in the File Name field if it is required.  

http://www.socialsecurity.gov/bso/bsowelcome.htm
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7. Click Create File. Or choose Save to store the information for creating the file later. Choosing 

Save will also save changes in the Electronic Filer Submitter Information window. 

8. If a message is displayed stating that not all fields have been entered, choose Submitter and 

verify that the information is complete. 

9. The W-2 Electronic Filing Summary Report is printed after the EFW2 file is created. This report is 

for informational purposes only. 

Remember to obtain your User ID number from the Social Security Administration website. 

Note: We recommend using AccuWage to check all magnetic media files before sending. This is a free 

tool available from the Social Security Administration (SSA) website 

(www.socialsecurity.gov/employer/accuwage).  

Step 11:  Archive inactive employee human resources information (Optional) 

To archive inactive employee human resources information: 

Go to Microsoft Dynamics GP > Tools > Utilities > Human Resources > Select Employee. Click Archive. 

Step 12: Create the human resources attendance period schedules for the new year 

1. If using the Human Resources module, you will need to create the attendance period schedules 

for the new year.   

2. Go to Microsoft Dynamics GP > Tools > Setup > Human Resources > Attendance > Accrual 

Periods. 

3. Change the year to 2023 and click on the pay period(s) that you use. In this screen, define your 

pay periods for 2023.   

4. Confirm that there is no lapse of dates between the 2022 pay periods and the 2023 pay periods. 

To verify, open up the 2023 pay period setup screen to check the last date of the last pay period. 

The next day will be the first date of the first pay period in the next year. Also, verify the Current 

Year field by going to Microsoft Dynamics GP > Tools > Setup > Human Resources > Attendance 

> Setup. The year should read 2023. 

5.  Step 13: Set up Fiscal Periods for 2023 

To set up fiscal periods for 2023: 

1. Go to Microsoft Dynamics GP > Tools > Setup > Company > Fiscal Periods. 

2. Type in the new year. 

3. Enter the First and Last Day of the Fiscal Year. 

4. Click Calculate. 

http://www.socialsecurity.gov/employer/accuwage
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5. Adjust Period Beginning Dates, as needed. 

6. Click OK to Save your Changes.  

Note: You may want to close all periods, except period 1, to prevent users from posting to future periods.  

  



Microsoft Dynamics GP 

Payroll Year-End Update and closing  Page 52 

©2022 RSM US LLP 

Step 14:  Delete human resource information for inactive employees (Optional) 

The Remove Inactive Records window deletes inactive records in both Payroll and Human Resources 

tables. 

Make sure you do not delete inactive records until after you’ve created the Year-End Wage file and 

printed all government statements and reports for the year. Once inactive employee records are removed, 

you will not be able to reprint statements and reports. You should also make sure to archive all employee 

information that you want to keep. 

1. To remove inactive records, go to Microsoft Dynamics GP > Tools > Utilities > Payroll > Remove 
Inactive Records. 
 

 

2. Choose the type of information to delete. If you mark Remove Inactive Employee Records and do 
not mark Remove History for Inactive Employees, information for Payroll history reports will be 
retained. 
 

3. Choose Process. When processing is complete, the Remove Inactive Employee 
Records Utility Log will be printed. 

Step 15: Close the Fiscal Periods for the Payroll Series 

To ensure that no one posts transactions to an incorrect period or year, use the Fiscal Periods Setup 

window to close any fiscal periods that are still open for the year. 

Go to Microsoft Dynamics GP > Tools > Setup > Company > Fiscal Periods  

Make sure that you have posted all transactions for the period and year for all modules before closing 

fiscal periods. If you later need to post transactions to a fiscal period you have already closed, use the 

Fiscal Periods Setup window to reopen the period before posting the transaction. Mark the periods you 

wish to close under Payroll Series. 
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Step 16: Install the 2023 Payroll Tax Table Update 

Note: Do not install the payroll tax update for 2023 until the year-end wage file has been created for 

2022. 

To install the payroll tax update for 2023: 

1. Go to Microsoft Dynamics GP > Maintenance > U.S. Payroll Updates > Check for Tax Updates. 

2. In the Tax Update Method window, click Automatic and then click Next.  

3. In the Authorization Number field, type your company’s authorization number and then click Log 

In.  

4. Click Finish.  

Note: This update can also be downloaded manually from the link below:   

US Payroll Tax Update for Microsoft Dynamics GP 

Processing 2023 Pay Runs Before Printing 2022 Statements 

1. Verify the version of Microsoft Dynamics GP installed and that you have installed the latest 2022. 

Payroll tax updates.  

2. Complete all pay runs for the current year.  

3. Complete all monthly and quarterly payroll period-end procedures for the current year. (Optional) 

4. Make a backup of the company database labeled “Pre Year-End Wage File”. 

5. Install the 2022 Year-End Update.  

6. Create the Year-End Wage file.  

7. Make a backup of your company database labeled “Post Year-End Wage File”. 

8. Verify W-2 and 1099-R statement information.  

9. Archive inactive employee human resources information. (Optional) 

10. Create the human resources attendance period schedules for the new year. 

11. Set up fiscal periods for 2023. 

12. Delete human resources information for inactive employees. (Optional) 

13. Close the fiscal periods for the Payroll series for 2022. (Optional) 

14. Install the payroll tax update for 2023.  

15. Process 2023 pay runs. 

16. Print the W-2 and 1099 Validation Reports, W-2 and 1099-R Statements and W-3 and 1096 Forms. 

https://docs.microsoft.com/en-us/dynamics/s-e/gp/tugp2018_391
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17. Prepare and submit W-2 information in the federal EFW2 format, if required. 

Detailed steps for processing 2023 pay runs before printing 2022 statements 

Step 1: Verify the version of Microsoft Dynamics GP and the latest 2023 Payroll Tax Updates that 

is currently installed. 

The 2022 Payroll Year-End Update and the 2023 Payroll Tax Updates will be available for the following 

version only: 

• Microsoft Dynamics GP 18.5 xxxx– Year End Changes included with latest release 

To verify your version information, log in to Microsoft Dynamics GP. On the home page, click on (?) 

Button > About Microsoft Dynamics GP.  

To verify the latest 2022 Payroll tax update currently installed, go to Tools > Setup > System > Payroll 

Tax.  

Step 2: Complete all pay runs for the current year  

It is important that you complete all pay runs for 2022 before you install the 2023 Payroll Tax Update 

Round 1. If you install the 2023 Payroll Tax Update prior to completing your 2022 pay runs, taxes will be 

calculated at 2023 rates for the remainder of the 2022 pay runs. In addition, if the 2023 Tax Update is 

installed prior to creating the Year-End Wage file, your W-2s will report incorrect information. 

Step 3: Complete all payroll month and quarter-end procedures (Optional)  

For more information about period-end procedures for payroll, view Chapter 21, "Payroll Company 

Routines," in the Microsoft Dynamics GP user's manual. 

Step 4: Make a backup of the company database and label it “Pre Year-End Wage File” 

Make a backup before you close the year. Place the backup in safe, permanent storage. This backup 

ensures that you have a permanent record of the company's financial position at the end of the year and 

allows you to quickly restore the information in the event a power fluctuation or some other problem 

occurs during the year-end close procedure. See the section on Backups under General Tips and 

Reminders for more information on creating backups 

Note: It is highly recommended that you backup the files Reports.dic, Forms.dic and Dynamics.vba in 
your application before installing the U.S. 2022 Year-End Update. 

Step 5: Install the Year-end update 

To install the Payroll Year-end update, follow the installation instructions provided with the update. The 

update must be installed on the server and each computer that has Microsoft Dynamics GP installed. Do 

not restart Microsoft Dynamics GP on any workstation until the update has been installed on all 

workstations that run Microsoft Dynamics GP. 
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Step 6: Create the Year-end file 

 

Go to Microsoft Dynamics GP > Tools > Routines > Payroll > Year-End Closing. In the Year field, type 

2022 and then click Process.  

Note: You can install the payroll tax update for 2023 any time after the Year-end file for 2022 has been 

created. 

Step 7: Make a backup of the new file of the company database and label it “Post Year-End Wage 

File”  

Make a backup and then put this backup into safe, permanent storage. By creating a backup, you make 

sure that you have a permanent record of the company's financial position at the end of the year. You can 

restore the backup to quickly recover data if a power fluctuation or other problem occurs during the year-

end closing procedure. 

Step 8: Verify W-2 and 1099-R statement information 

 

 

To view W-2 information in Microsoft Dynamics GP, go to Microsoft Dynamics GP > Tools > Routines > 

Payroll > Edit W-2s. 

To view the 1099-R information in Microsoft Dynamics GP, go to Microsoft Dynamics GP > Tools > 

Routines > Payroll > Edit 1099-Rs. 

Note: If you change the W-2 or the 1099-R information, we recommend that you make another backup. 

Step 9: Archive inactive employee human resources information (Optional) 
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To archive inactive employee human resources information: 

Go to Microsoft Dynamics GP > Tools > Utilities > Human Resources > Select Employee. Click Archive. 

Step 10: Create the human resources attendance period schedules for the new year 

If using the Human Resources module, you will need to create the attendance period schedules for the 

new year.   

1. Go to Microsoft Dynamics GP > Tools > Setup > Human Resources > Attendance > Accrual 

Periods. 

2. Change the year to 2023 and click on the pay period(s) that you use. In this screen, define what 

your pay periods are for 2023.   

3. Confirm that there is no lapse of dates between the 2022 pay periods and the 2023 pay periods. 

To verify, open up the 2022 pay period setup screen to check the last date of the last pay period. 

The next day will be the first date of the first pay period in the next year. Also, verify the Current 

Year field. by going to Microsoft Dynamics GP > Tools > Setup > Human Resources > 

Attendance > Setup. The year should read 2023. 

Step 11: Set up Fiscal Periods for 2023 

To set up fiscal periods for 2023: 

1. Go to Microsoft Dynamics GP > Tools > Setup > Company > Fiscal Periods. 

2. Type in the New Year. 

3. Enter the First and Last Day of the Fiscal Year. 

4. Click Calculate. 

5. Adjust Period Beginning Dates as needed. 

6. Click OK to save your changes.  

Note: You may want to close all periods, except period 1, to prevent users from posting to future periods.  

Step 12: Delete human resource information for inactive employees (Optional) 

The Remove Inactive Records window deletes inactive records in both Payroll and Human Resources 

tables. 

Make sure you do not delete inactive records until after you’ve created the Year-End Wage file and 

printed all government statements and reports for the year. Once inactive employee records are removed, 

you will not be able to reprint statements and reports. You should also make sure to archive all employee 

information that you want to keep. 
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1. To remove inactive records, go to Microsoft Dynamics GP > Tools > Utilities > Payroll > Remove 
Inactive Records. 

 

2. Choose the type of information to delete. If you mark Remove Inactive Employee Records and do 
not mark Remove History for Inactive Employees, information for payroll history reports will be 
retained. 
 

3. Choose Process. When processing is complete, the Remove Inactive Employee 
Records Utility Log will be printed. 

Step 13: Close the Fiscal Periods for the Payroll Series 

To ensure that no one posts transactions to an incorrect period or year, use the Fiscal Periods Setup 

window to close any fiscal periods that are still open for the year. 

Go to Microsoft Dynamics GP > Tools > Setup > Company > Fiscal Periods  

Make sure that you have posted all transactions for the period and year for all modules before closing 

fiscal periods. If you later need to post transactions to a fiscal period you have already closed, use the 

Fiscal Periods Setup window to reopen the period before posting the transaction. Mark the periods you 

wish to close under Payroll Series. 
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Step 14: Install the 2023 Payroll Tax table Update 

Note: Do not install the payroll tax update for 2023 until the year-end file has been created for 2022. 

To install the payroll tax update for 2023: 

1. Go to Microsoft Dynamics GP > Maintenance > US Payroll Updates > Check for Tax Updates 

2. In the Tax Update Method window, click Automatic and then click Next.  

3. In the Authorization Number field, type your company’s authorization number and then click  

Log In.  

4. Click Finish.  

Note: This update can also be downloaded manually from the link below:   

US Payroll Tax Update for Microsoft Dynamics GP 

Note: To process pay runs for 2023 prior to printing W-2 forms, you must change the user date to a 2023.               

Step 15: Process 2023 Pay Runs 

Step 16: Print the W-2 Validation Reports, W-2 Statements and W-3 Transmittal Form 

1. Go to Microsoft Dynamics GP > Tools > Routines > Payroll > Print W-2s. 

2. Select the option to Print the Validation Report. 

The report displays warnings if there are employee record errors, except for employees with no wages, 

tips or withholding information entered on their W-2 form. W-2 forms will not be printed for employees with 

no earnings or withholding information.   

 

If you see errors on the Validation Report, you will need to REMOVE the Year-End information before 

making changes. Make corrections as needed and then Create the Year-End Wage file again.     

https://docs.microsoft.com/en-us/dynamics/s-e/gp/tugp2018_391
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Go to Microsoft Dynamic GP > Tools > Utilities > Payroll > Remove Year-End Information. 

 
 

Select the year, Insert and Click Process. 

Note: The W-2 Validation Report will include all employees that exist within the Microsoft Dynamics GP 

database; however, only those employees with wages will actually print to the W-2 form.  

To print the W-2 statements in the Print W-2 Forms window, specify the following settings: 

1. Print W-2s for: Normal Year-End  

2. Print: W-2 Forms  

3. Click Print  

Note: You can print employee W-2 statements as many times as needed. 

 

To print the W-3 Transmittal Form, select the option to print the W-3 Transmittal Form and click Print.  

Note: You can print the W-3 Transmittal Form as many times as needed. 

To view 1099-Rs, you will also print the 1099-R Validation Report: 

1. Go to Microsoft Dynamics GP > Tools > Routines > Payroll > Print 1099-Rs. 
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2. Select the option to Print the Validation Report. 

 

If you see errors on the Validation Report, you will need to REMOVE the Year-End information before 

making changes. Make corrections as needed and then Create the Year-End Wage file again.     

Go To Microsoft Dynamic GP > Tools > Utilities > Payroll > Remove Year-End Information. 

If you make changes to your 1099-R records or W-2 records, we recommend that you make another 

backup.  

Note: W-2s and 1099-Rs can be printed any time after the data has been validated. 

To print the 1099 forms, in the 1099-R Forms window, select the year, click 1099-R Forms and click Print.  

Note: You can print employee 1099-R forms as many times as needed. 

To print the 1096 Transmittal form in the Print 1099-R Forms window, select the year, click 1096 

Transmittal Form and click Print.  

Note: You can print the 1096 Transmittal form as many times as needed. 

Step 17:  Prepare and submit W-2 information in the federal EFW2 format, if required. 

If you plan to submit W2s electronically, the U.S. W-2 Magnetic Media feature must be registered for 

Microsoft Dynamics GP. To verify this, choose Help >> About Microsoft Dynamics GP and choose 

Options. Scroll through the list of registered modules to find U.S. W-2 Magnetic Media. A check mark 

indicates it is registered.  You will then need to register for a User Identification Number (UIN) with the 

Social Security Administration. You only need to register once for a UIN. After you’ve obtained your UIN, 

you may use it indefinitely, provided you change your password once a year.  
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To obtain a UIN and find more information about the electronics submission formats and free accuracy 

checking, visit the link below: 

www.socialsecurity.gov/bso/bsowelcome.htm 

Microsoft Dynamics GP currently supports filing magnetic media for federal W-2 information in an 

MMREF-1 format. Some states also accept this format. 

Magnetic media filing of 1099-Rs, state W-2s, State Unemployment Tax Act (SUTA) or formats other than 

MMREF-1 are not supported. You will need to use separate software or services for filing these items. 

Contact your local RSM representative or the support desk for more information on obtaining compatible 

magnetic media products. 

1. To create a magnetic media file, go to Microsoft Dynamics GP > Routines > Payroll > W-2 

Magnetic Media. 

2. In the Magnetic Media window, click to select the checkbox that is next to each company that you 

want to include in your magnetic media file.  

3. In the UIN field, enter the UIN.  

4. Click Submitter. The Magnetic Media Submitter Information window opens.  

5. Enter the authorized submission information.  

6. Close the Magnetic Media Submitter Information window.  

7. Change the file destination information in the File Name field if it is required.  

8. Click Create File. Or choose Save to store the information for creating the file later. Choosing 

Save will also save changes in the Electronic Filer Submitter Information window. 

9. If a message is displayed stating that not all fields have been entered, choose Submitter and 

verify that the information is complete. 

10. The W-2 Electronic Filing Summary Report is printed after the EFW2 file is created. This report is 

for informational purposes only. 

 

Remember to obtain your UIN number from the Social Security Administration website. 

http://www.socialsecurity.gov/bso/bsowelcome.htm
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Note: We recommend using AccuWage to check all magnetic media files before sending. This is a free 

tool available from the Social Security Administration (SSA) website 

(www.socialsecurity.gov/employer/accuwage).  

Payroll year-end closing frequently asked questions 

Q1.  What will happen if I’ve already closed the 2022 Payroll tax year and do not install the 2023 

tax update right away? 

Until you install the 2023 tax update containing Federal Insurance Contributions Act (FICA), federal 

and state tax changes, the tax calculations for your 2023 pay runs may be incorrect. 

Q2.  If I use multiple companies with my accounting system, do I have to install the year-end tax 

update for each company? 

No, the program automatically will update the system tables containing payroll tax information. All of 

the companies will reflect the update. However, you do need to install the update on each 

workstation. 

Q3.  I need to print my 2023 checks before I can print W-2s. What should I do? 

After you create the Year-End Wage file, close the year. Install the 2023 tax update and then you 

can print checks. 

Q4.  Can I print four W-2 statements to a page? 

You can print four W-2 statements to a page using the 4-Up Laser Form. Four statements for the 

same employee will print per page. The form contains Copy B, Copy C and two Copy 2 forms. Copy 

A and Copy D must be printed separately. You can also print W-2s in the 1-Wide Continuous, 2-

Wide Continuous and 1-Wide Single Feed forms. 

Q5.  How do I print multiple W-2 statements for each employee? 

There are two ways: 

1. Using Laser form “sets” – To print all the required forms for each employee at a time (you’re 

using laser form “sets”), simply enter the number of copies you need to print in the “Number of 

Copies” field in the Print dialog box that appears after you choose Print in the Print W-2 Forms 

window.  

2. Using Laser form “sheets” – To print all forms for all employees, repeat the Printing W-2 

Statements procedure as many times as necessary to print the required number of copies. 

Alternatively, print the W-2s to the screen, then click the Print button for each group of sheets. 

Q6.  I can’t make W-2 forms align correctly. What can I do? 

http://www.socialsecurity.gov/employer/accuwage
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Try the following method to correct alignment issues: 

1. Print the W-2s to screen. 

2. Choose the printer icon button on the top left. 

3. A print dialog box with horizontal and vertical alignments will appear on the right. Adjust according 

to the situations below: 

Problem Adjustment 

Form prints too high Enter a positive vertical adjustment (.25 is one line) 

Form prints too low Enter a negative vertical adjustment (-.25 is one line) 

Form prints too far right Enter a negative horizontal adjustment 

Form prints too far left Enter a positive horizontal adjustment 

Q7.  How do I verify federal withholding taxes? 

If an employee’s federal withholding taxes seem incorrect or you want to verify the amounts, follow 

these steps to help pinpoint the error source. 

1. Verify your employee’s records in the Payroll Employee Tax Maintenance window.   

2. Go to Cards > Payroll > Tax.  

3. Check to see if any additional amounts have been entered in the Additional Withholding and 

Estimated Withholding fields. 

4. Open the Benefit Setup window.  

5. Go to Microsoft Dynamics GP > Tools > Setup > Payroll > Benefit. 

6. Verify that all benefits are marked as a tax shelter annuity (TSA) if they are supposed to be. 

7. Be sure that the pay frequency of the employee’s pay codes matches the pay period of your 

company. For example, if you pay your employees semimonthly, the pay frequency for the 

employee’s pay code, deduction and benefit should also be semimonthly. 

Q8.  How can I edit FICA Social Security wage limits? 

If FICA amounts are being printed incorrectly on W-2s – for example, if your employee has reached 

the FICA limit, but the form doesn’t reflect that status -- you may have tried to edit the information, 

but find that the forms still print the wrong information. That’s because the FICA Social Security limit 

is hard-coded and can’t be edited for W-2 purposes. Instead, check to see if the year-end wage file 

was created with old tax tables and an old FICA Social Security limit. If so, you won’t be able to edit 

the figures so they print correctly on W-2s. To correct the information, you’ll need to either recreate 

the year-end wage file after making changes in the Payroll Tax Setup window or add the Edit Social 

Security Wage Limit window to the Shortcut bar. 

To change the information in the Payroll Tax Setup window: 



Microsoft Dynamics GP 

Payroll Year-End Update and closing  Page 64 

©2022 RSM US LLP 

Go to Microsoft Dynamics GP > Tools > Setup > System > Payroll Tax 

Edit the FICA limit and recreate the year-end wage file.  

To the Edit Social Security Wage Limit window to the Shortcut bar:  

1. From the Navigation Pane, select the drop-down button to configure buttons.   

2. Select Add > Add Window. 

3. Expand Microsoft Dynamics GP and then expand Payroll. 

4. Highlight Edit Social Security Wage Limit under Payroll and click Add. Then click Done. 

5. Choose the Edit Social Security Wage Limit window from the Shortcut bar, choose 2023 

and change the wage limit to the correct amount for 2023. Click Ok.  

Changes will be reflected on the W-2s, but not in the Payroll Tax Setup window. This will allow you 

to proceed with 2023 pay runs without needing to change information if the 2023 tax update has 

been installed. 

Q9.  The correct Last Year-End Update date doesn’t appear in the Payroll Setup window, even 

though I installed the 2022 Year-End Update and see the form changes included in the 

Update. Is there something I need to do? 

The Last Year-End Update date is read from the LastYearEndUpdate= line in the Dex.ini file. When 

you install a year-end update on a particular computer, the Dex.ini file on that computer is updated. 

However, in some Windows Terminal Server deployments, there is only a single installation of 

Microsoft Dynamics GP, which many users access. Each user typically has a Dex.ini file in their 

home Windows folder. Installing the year-end update on the server doesn’t update each user’s 

Dex.ini file. In these situations, you should manually update each user’s Dex.ini file, so that the 

appropriate line reads LastYearEndUpdate=11/19/2022. 

Q10.  After running the reconcile function for an employee, the Federal Unemployment Tax Act 

(FUTA) and SUTA Taxable amount is being changed in their Employee Summary screen. 

Why? 

The change is for deduction amounts that were set up to be SUTA-taxable in the Unemployment 

Tax Setup, but are TSA deductions, and therefore, are being deducted from the SUTA wages. The 

reconcile feature will not calculate the amounts of TSA deductions that are set up to be included in 

taxable wages in the Unemployment Setup window (Tools > Setup > Payroll > Unemployment). 

Instead, it will reduce the amounts by the employee’s current TSA amounts. 

The FUTA/SUTA amounts on the Employee Summary window are listed for informational purposes 

only.  These amounts will not be used to calculate, nor will they affect the FUTA and SUTA reports. 

The amounts displayed on the summary window, however, will appear on the Detailed Employee 

list report. 
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We recommend running the reconcile process (Tools > Utilities > Payroll > Reconcile) and only 

printing the report the first time, not actually reconciling. If you have selected TSA deductions to be 

included as taxable wages, disregard any proposed changes to FUTA or SUTA wages on the 

report. If you have not, research proposed changes to FUTA or SUTA wages. In either case, you 

should research any proposed changes to any other amounts on the report. 

Q11.  In both the Edit W-2 Information and the Print W-2 Forms windows, there is a list from which 

to select the year. Is there a limit to the number of years? Also, is each year simply added to 

the Year-End Wage file or does each year have its own Year-End Wage file that is created 

during the year-end closing process?  

During the Payroll year-end closing process, the Year-End Wage File is created. Multiple years of 

history can be saved. However, if you choose the same year (for example, 2022) twice when 

performing this process, the previous file will be written over, or replaced, by the new file. As long 

as the correct year is entered each time, the new year's information will be added to the file. This 

information can be removed under Utilities-Payroll for any year or years. 

Q12.  In the Year-End Wage Report window, there is a selection list that is used to specify the year 

for which you wish to print the Year-End Employee Wage report. Does this mean that the 

Year-End Wage file is not removed after printing W-2 statements? Using Report Writer, can I 

access the Year-End Employee Wage report and create a report showing year-end 

information for multiple years?  

The information for each year is kept in the system and can be accessed through Report Writer or 

Crystal Reports.  

Q13.  I have printed a Year-End Wage report and now want to run another pay run within the year 

for which I created the Year-End Wage report. How can I do this?  

You must remove the year-end information, make the changes and then create the Year-End Wage 

file again.   

To remove the Year-End Wage file, go to  Microsoft Dynamics GP > Tools > Utilities > Payroll > 

Remove Year-End Information. 

To reclose the year, go to Microsoft Dynamic GP > Tools > Routines > Payroll > Year-End Closing. 

Enter the year that you want to close and click Process. 

Q14.  I want to make a change to an employee record in the closed year to correct their W-2, but I 

have already processed payroll in the new year. Can I do that? 

Yes, you may recreate the Year-End Wage file, even after you have run payroll for the next year. 

The payroll module is date-sensitive. Therefore, your payroll and W-2 reports will only include the 

wages that apply to the year that you are reporting. The process is the same as in the previous 

question. 
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Fixed Assets Year-End closing procedures 

Be sure to install the 2022 Year End Update as there is change to Luxury Auto Maximum Depreciation 

Deduction Amounts.  The maximum depreciation deduction amounts allowed for luxury vehicles has been 

updated for assets placed in service in calendar year 2022 to comply with IRS Guidelines: 

The Fixed Assets module is not date-sensitive. You must run the Fixed Asset Year-End routine prior to 

processing any Fixed Asset transactions for the new year. 

It is also very important that you close Fixed Assets prior to processing the Year-End in general ledger.  

Fixed Asset Management year-end checklist  

1. Complete the year-end closing procedures for Payables Management.  

2. Enter all the Fixed Asset transactions for the current fiscal year. 

3. Depreciate all assets through the last day of the current fiscal year.  

4. Perform the GL Posting (GL Interface) process (Optional). 

5. Print any year-end reports that you want to keep as part of the year-end financial records.  

6. Verify that the Fixed Assets calendar is built correctly (Optional). Verify that the quarters are set 

up correctly for all the fiscal years.  

7. Make a backup. 

8. Perform the fixed assets year-end closing routine. 

Detailed information for each step in the year-end checklist  

Step 1: Perform all the Year-End Closing procedures for Payables Management 

Make sure you have completed the Payables Management Year-End Closing Routine. This guarantees 

that all the outstanding fixed asset transactions have been capitalized.  

Step 2: Enter all the Fixed Asset Transactions for the current fiscal year 

Post all additions, changes, transfers and retirements for the current fiscal year. 

Note: Transfers and Undo Retirement Transactions should never be performed in a historical year.  

  

https://www.irs.gov/pub/irs-drop/rp-19-26.pdf
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Step 3: Depreciate all assets through the last day of the current fiscal year 

 

1. Go to Microsoft Dynamics GP > Tools > Routines > Fixed Assets > Depreciate. 

2. In the Depreciation Target Date box, type the last date of the current fiscal year.  

3. To insert all the fixed asset books, click All.  

4. Click Depreciate.  

Step 4: Perform the GL Posting (GL Interface) process (Optional) 

 

1. Go to Microsoft Dynamics GP > Tools > Routines > Fixed Assets > GL Posting. 

2. In the Beginning Period box, type the year and the last period of the year.  

3. In the Ending Period box, type the year and the last period of the year.  

4. In the Transaction Date box, type the last date of the current fiscal year or type the date when you 

need the posting to affect the general ledger.  

5. Click Continue.  

6. When you receive a message that the batch number is being created, click Continue.   

7. In the Report Destination window, click to select the Printer checkbox and then click OK.  

Note: You may want to keep this report as part of the year-end financial records.  
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Step 5: Print any Year-End reports that you want to keep as part of the Year-End Financial records 

Note:  In Microsoft Dynamics GP 2013 and beyond, historical reporting functionality has been added. 

Prior version of Dynamics GP did not have this capability, and you were required to print any Fixed Asset 

reports with year-to-date depreciation amounts prior to processing the close. In Microsoft GP 2013 and 

later versions the reports can be printed at any point in time. 

There are several reports available for fixed assets. We recommend that you print the following reports:  

• Annual Activity (Reports > Fixed Assets > Activity > Annual Activity) 

• Additions (Reports > Fixed Assets > Transaction > Additions) 

• Retirements (Reports > Fixed Assets > Transaction > Retirements) 

• Transfers (Reports > Fixed Assets > Transaction > Transfers) 

• Depreciation Ledger (Reports > Fixed Assets > Depreciation > Depreciation Ledger) 

• Property Ledger (Reports > Fixed Assets > Inventory > Property Ledger) 

• Fixed Assets to General Ledger Reconciliation (Reports > Fixed Assets > Activity> Fixed Assets 

to General Ledger Reconciliation) 

If you have more than one fixed asset book, we recommend that you also print the following reports: 

• Book -to-Book Reconciliation (Reports > Fixed Asset > Comparison) 

• Book-to-Book YTD Depreciation Comparison (Reports > Fixed Asset > Comparison > Book to 

Book YTD Depreciation) 

Step 6: Verify the Fixed Assets Calendar is built correctly (Optional) 

1. Go to Microsoft Dynamics GP > Tools > Setup > Fixed Assets > Calendar. Select the Calendar ID 

and the year. 

 

2. Click Verify. When you are prompted to verify the periods, click OK.  

3. In the Report Destination window, click Screen and then click OK. 
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Note: The Message column of the report must say OK. If the Message column says Missing for any line, 

see question 1 in the Frequently Asked Questions (FAQ) section.  

Step 7: Verify that the Quarters are set up correctly for all the fiscal years 

 

1. Go to Microsoft Dynamics GP > Tools > Setup > Fixed Assets > Quarter, or click on the Quarters 

button from the Calendar ID setup window.  

2. Make sure that the following boxes are not empty: 

• Start Date  

• End Date  

• Mid Date  

Note: These boxes must exist for each quarter. If any box is empty, type the appropriate date in that box.  

Step 8: Make a backup 

Make a backup before you close the year. Place the backup in safe, permanent storage. This backup 

ensures that you have a permanent record of the company's financial position at the end of the year and 

allows you to quickly restore the information in the event a power fluctuation or some other problem 

occurs during the year-end close procedure. See the section on Backups under General Tips and 

Reminders for more information on creating backups 

Step 9: Perform the Fixed Assets Year-End Closing routine 
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1. Go to Microsoft Dynamics GP >Tools > Routines > Fixed Assets > Year-End. 

2. Verify that the fiscal year that is displayed for each book is the current fiscal year. (The current 

fiscal year is the year that you are closing.) 

Note: If the fiscal year that is displayed for a book is not the current fiscal year, see question 2 in the 

"Frequently Asked Questions (FAQ)" section.  

3. Click the book that you want to close and then click Insert. Repeat this step until all the books that 

you want to close have been inserted.  

4. Click Continue. 

Note:  The Fixed Asset Year Closing routine accomplishes the following tasks: 

• In the Asset General Information window, the Quantity field is copied to the Begin Quantity field of 

the Expand Quantity window.  

• In the Expand Last Maintenance window, the YTD Maintenance amount is cleared.  

• In the Asset Book window, the YTD Depreciation Amount is cleared.  

• The Cost Basis field is copied to the Begin Year Cost field.  

• The LTD Depreciation field is copied to the Begin Reserve field.  

• The Salvage Value field is copied to the Begin Salvage field.  

• In the Book Setup window, the Current Fiscal Year field is increased by one.  

Note: For GP 2015 and higher versions, you will be prompted to print the Fixed Assets Year End Closing 

report.  

Frequently asked questions (FAQ) 

Q1.  The fiscal year that is displayed for my book in the Asset Year-End window is not 2022. I 

closed 2021 last year, and I have not yet closed 2022. What should I do? 

See the answer for question 4. 

Q2.  I have closed General Ledger in Microsoft Dynamics GP, and I now realize that I have not yet 

closed Fixed Asset Management. Can I perform the fixed assets year-end closing routine at 

this point? 

A2: We recommend that you close General Ledger last, after all the subsidiary modules have been 

closed. However, Fixed Asset Management can be closed after General Ledger is closed. The GL 

Posting (GL Interface) process can be performed, and then the transaction or transactions can be 

posted to the closed year or to the historical year in the general ledger. For more information about 
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the GL Posting (GL Interface) process, see step 4 in the "Year-end checklist" section. 

 

To post transactions to the historical year in the general ledger, make sure that the following options 

are selected in the General Ledger Setup window: 

• Allow Posting to History 

• Maintain History Accounts 

• Maintain History Transactions 

Notes 

• To access the General Ledger Setup window in Microsoft Dynamics GP, point to Tools on the 

Microsoft Dynamics GP menu, point to Setup, point to Financial, and then click General 

Ledger. 

The posted transaction will update the historical year, and it will roll forward as a beginning balance 

to the open year. If any expense accounts or any revenue accounts were included in the transaction, 

they will automatically close out to the Retained Earnings account or accounts. 

Q3.  I ran the year-end routine in Fixed Asset Management, and then I ran depreciation in the new 

year. I see that the depreciation is highly overstated and that some assets have a negative 

number in the "Net Book Value" field. Why is the system calculating so much depreciation? 

This problem occurs if the following conditions are true: 

• The year was closed.  

• The assets were not depreciated through the last day of the fiscal year.  

• Consider the following example: 

• The fiscal year is a calendar year (January 1 through December 31).  

• The assets were depreciated through December 28, when the year was closed.  

In this example, depreciation will be incorrect the next time that depreciation is run. The system does 

not recalculate the yearly rate when the year-end closing routine is performed. Therefore, fixed 

assets take a full year of depreciation in the last few days that remain in the previous year 

(December 29 through December 31). The rate of depreciation is the yearly rate currently on each 

asset. Additionally, if there are assets that are near the end of their original life, the Net Book Value 

field may become negative. There are two workarounds for this problem: 

Restore the data from a backup, run depreciation through the last day of the year and then perform 

the year-end closing procedures.  

Reset life on all the assets.  
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Note: If amounts on the assets have ever been entered for the YTD Depreciation field or for the LTD 

Depreciation field, resetting life on the assets will change these amounts and the result may be 

different. If you change the YTD Depreciation field or the LTD Depreciation field by resetting life on 

the asset, you will cause inconsistencies between Fixed Asset Management and general ledger. 

These inconsistencies must be explained. 

Q4.  Instead of completing the year-end routine for Fixed Asset Management, I manually changed 

the "Current Fiscal Year" field in the Book Setup window to the next year. Do I have to go 

back and run the year-end closing routine, or can I continue to process activity in Fixed 

Asset Management for the new year? 

If no activity, such as additions, changes, transfers, retirements or depreciation, has been run for the 

new year, the Current Fiscal Year field in the Book Setup window can be changed back to the 

previous year, and then the year-end closing routine can be processed. 

If any activity, such as additions, changes, transfers, retirements or depreciation, has been run for 

the new year, restore the data from a backup and then continue with the year-end closing routine. 

In either situation, the year-end closing routine must be run. If the year-end closing routine is not 

completed, the amount in the YTD Depreciation field will be overstated on any report that includes 

assets that were retired or that were fully depreciated in the previous year. If the year-end closing 

routine is not performed, the amounts in the YTD Depreciation field will not be cleared. The amounts 

in the YTD Depreciation field will not be zeroed out. Therefore, these amounts will be incorrectly 

included in the reports for the new year.
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General Ledger Year-End closing procedures 

During the year-end closing routine, all the records will be moved from the GL20000 Year to Date Open 

table to the GL30000 History table and placed in a temporary table, before they are permanently moved 

to the GL30000 History table. You must have free disk space that is equal to the size of the GL20000 

table to perform the routine. 

Note: For customers that began using the Analytical Accounting (AA) module prior to GP 10.0 SP2, and 

then later upgraded to the current version, you will need to follow the steps outlined in the section of this 

document entitled: Analytical Accounting Year-End Closing Procedures. You will only be required to run 

this process one time. Also, you will complete the Analytical Year-End Closing steps prior to closing the 

GL module.   

For customers that began using Analytical Accounting with Microsoft Dynamics GP 10.0 Service Pack 2 

and later, functionality was added to consolidate balances for dimensions in Analytical Accounting, and 

there is no separate year-end process that needs to be run in the Analytical Accounting module. When 

the year-end close process is run for general ledger, it will automatically consolidate the balances and 

move the transactions in Analytical Accounting for dimensions that were properly marked. If this is the 

case, you will still need to review knowledge base (KB) article 960356, referenced in the Analytical 

Accounting section of this document, to make sure you have properly marked the dimensions that you 

want to be consolidated during the year-end process.  

Microsoft Dynamics GP 2013 and later versions contain some new features and functionality for the Year-

End close routine. These features will be highlighted and further explained in the General Ledger Year-

End Checklist and subsequent detailed steps. 

General ledger year-end checklist 

1. Complete the posting procedures and the closing procedures for other modules. 

2. Post the final adjusting entries in general ledger.  

3. Create a SmartList to verify the posting type of each account.  

4. Optional: Close the last period of the fiscal year. 

5. Optional: Perform file maintenance on the Financial Series group of modules.  

6. Verify the settings in the General Ledger Setup window.  

7. Optional: Select to Clear Balances of Unit Accounts – NEW FEATURE for Microsoft 

Dynamics GP 2013 and later versions. 

8. Make a backup.  

9. Print a final Detailed Trial Balance report (Optional). 

10. Print the year-end financial statements.  
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11. Set up a new fiscal year.  

12. Close the fiscal year – NEW FEATURES AVAILABLE IN THE YEAR–END CLOSE WINDOW 

for Microsoft Dynamics GP 2013 and later versions. 

13. Optional: Close all the fiscal periods for all the series. 

14. Adjust the budget figures for the new year and then print the financial statements.  

15. Create a final backup.  

Detailed information for each step in the year-end checklist  

Step 1: Complete the Posting and Closing procedures for other modules 

1. Post final transactions in all the modules except in general ledger. 

2. Complete the month-end procedure and the quarter-end procedure for all the modules, except 

general ledger. 

3. Complete the year-end closing procedures for each module in the following order: 

a) Inventory 

b) Payables Management 

c) Receivables Management 

d) Fixed Assets 

e) Analytical Accounting -- Note: For Microsoft Dynamics GP 10.0 Service Pack 2 and 

greater, functionality was added to consolidate balances for dimensions in Analytical 

Accounting. Please review the section in this document entitled Analytical Accounting 

Closing Procedures for further details and information. Please note that there is no menu 

option or separate year-end process that needs to be run in the Analytical Accounting 

module. When the year-end close process is run for general ledger, it will automatically 

consolidate the balances and move the transactions in Analytical Accounting for 

dimensions that were properly marked. However, you do need to review the steps 

provided in this document before proceeding with the general ledger close. 

f) General ledger 

Note: There are no required year-end procedures for Sales Order Processing, Purchase Order 

Processing or Bill of Materials. Payroll year-end procedures are independent of the other modules and 

are always performed at the calendar year-end.  
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Step 2: Post the Final Adjusting Entries in general ledger 

The adjusting entries include all the entries for which corrected errors were made when transactions were 

recorded. The adjusting entries also include journal entries that are used to assign revenues or expenses 

to the period in which the revenues were earned or in which the expenses were incurred. 

Use the Transaction Entry window or the Quick Journal Entry window to make adjusting entries in general 

ledger. 

If you have to track initial adjusting entries or post audit entries separate from other fiscal periods, 

auditing periods can be set up in general ledger. This feature enables separate tracking of the adjusting 

entries that are made after the year is closed.  

Note: If you are using closing periods and you reconcile, the transactions all move to the first period with 

the start date. 

Step 3: Create a SmartList to verify the posting type of each account   

The posting type determines whether an account is closed to the retained earnings account or whether an 

account brings a balance forward to the next fiscal year. If the account balance will be brought forward at 

the end of the year, the posting type must be set to Balance Sheet. If the account balance will be closed 

to a retained earnings account at the end of the year, the posting type must be set to Profit and Loss. Use 

the Account Maintenance window if you must change the posting type for an account. 

Follow these steps to verify that all accounts are set up with the correct posting type: 

Accounts mislabeled as Balance Sheet Posting Type: 

1. Use the SmartList object labeled Accounts to view all general ledger accounts, including the 

posting type.  

2. Use the Search window to set up two Search Criteria to look for accounts that should be profit 

and loss accounts, but are mislabeled as balance sheet posting type: 

a) Where the main segment is greater than your last balance sheet account 

b) Where the Posting Type equals the Balance Sheet 

c) Review the results and go to the Account card to change the posting type. 
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Accounts mislabeled as Profit and Loss Posting Type 

1. Use the SmartList object labeled Accounts to view all general ledger accounts, including the 

posting type. 

2. Use the Search window to set up two-search criteria to look for accounts that should be balance 

sheet accounts, but are mislabeled as profit and loss posting type: 

3. Where the main segment is less than your first revenue account 

4. Where the Posting Type equals Profit and Loss 

5. Review the results and go to the Account card to change the posting type. 

Step 4: Close the last period of the fiscal year (Optional) 

To ensure that no one posts transactions to an incorrect period or year, use the Fiscal Periods Setup 

window to close any fiscal periods that are still open for the year.  

Go to Microsoft Dynamics GP > Tools > Setup > Company > Fiscal Periods  

Make sure that you have posted all transactions for the period and year for all modules before closing 

fiscal periods. If you later need to post transactions to a fiscal period you have already closed, use the 

Fiscal Periods Setup window to reopen the period before posting the transaction. Mark the checkbox for 

the last period of the fiscal year under the Financial Series. 

Note:  If you use Microsoft FRx, keep one period in the most recent historical year open to prevent the 

following error message: “FRx Print Engine Failed to Load the Company Calendar”. 

Step 5: Perform file maintenance on all the Financial Series files (Optional) 

Go to Microsoft Dynamics GP > Maintenance > Check Links > Financial 

Run the Check Links procedure on the Financial series group of tables.  

 

 

Step 6: Verify the settings in the General Ledger Setup window 

Go to Microsoft Dynamics GP > Tools > Setup > Financial > General Ledger 
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If you want to keep historical records, you must click to select the Accounts checkbox and the 

Transactions checkbox in the Maintain History area of the General Ledger Setup window. The account 

history lets you print financial statements and calculate budgets from historical information. The 

transaction history lets you print detailed historical trial balances. The transaction history also lets you 

view the transaction details. If these checkboxes are selected, both the account history and the 

transaction history are updated during the year-end closing routine. 

You should also be sure that your Retained Earnings Account is correct. If you are closing to Divisional 

Account Segments, make sure that a retained earnings account exists for every divisional segment. 

Step 7: Select to clear balances of unit accounts (Optional) (NEW FEATURE Microsoft Dynamics 

GP 2013 and later versions ) 

Select the option to clear the balance of selected unit accounts during the year-end close. Previously, the 

unit account balances always carried forward to the next year. There is now a checkbox on the Unit 

Account Maintenance window to mark whether or not the balance should carry forward to the next year. 

For each unit account balance you would like to clear as part of the close process, go to Cards > 

Financial > Unit Account. Pull up each unit account individually and mark the option to Clear Balance 

During Year-End Close. 
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Step 8: Make a backup 

Make a backup before you close the year. Place the backup in safe, permanent storage. This backup 

ensures that you have a permanent record of the company's financial position at the end of the year and 

allows you to quickly restore the information in the event a power fluctuation or some other problem 

occurs during the year-end close procedure. See the section on Backups under General Tips and 

Reminders for more information on creating backups. 

Step 9: Print a final Detailed Trial Balance 

Reports > Financial > Trial Balance > Detail 

Note: We recommend that you post all transactions for the period and for the year for all modules before 

you print the Detailed Trial Balance report. If you post additional transactions later, we recommend that 

you print a new Detailed Trial Balance report. 

Step 10: Print final financial statements 

Print any year-end financial statements required. The most common financial statements include:  

• Balance Sheet 

• Profit and Loss Statement 

• Statement of Cash Flow 

• Statement of Retained Earnings 

Step 11: Set Up a new year in Fiscal Periods Setup  

Before you can perform a year-end closing, a new fiscal year must be set up using the Fiscal Periods 

Setup window. 

1. Go to Microsoft Dynamics GP > Tools > Setup > Company > Fiscal Periods. 

2. Type in the new year. 

3. Enter the first and last day of the Fiscal Year. 

4. Click Calculate. 

5. Adjust Period Beginning Dates as needed. 

6. Click OK to save your changes.  
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Step 12: Close the fiscal year  

 

To close the fiscal year, go to Microsoft Dynamics GP > Tools > Routines > Financial > Year-End Closing.  

1. Specify the Retained Earnings account to which the year's profit or loss will be closed. The 

default account is the one you entered in the General Ledger Setup window when you set up the 

module.  

• All current-year earnings or current-year losses will be transferred to the account you specify 

here. If you want to distribute the retained earnings for the year to more than one account, 

you can enter an allocation account to distribute the retained earnings amount to the 

appropriate accounts. For example, you could set up an allocation account to divide the 

earnings between several departments in your business.  

• Or, you could transfer the year's profit or loss to accounts that contain a specific account 

segment. This is referred to as a divisional retained earnings closing. See the FAQ section 

below for an example of closing to divisional retained earnings.  

2. Specify the starting journal entry number that will be used as the first journal entry number in the 

next fiscal year. You can either accept the default, which is one more than the highest posted 

journal entry number for the current year or enter a new number. The journal entry number you 

select will be used as the journal entry number for the Year-End Closing Report.  

3. In Microsoft Dynamics GP 2013 and later versions- Maintain inactive accounts - You now 

have the option to specify how to handle inactive accounts with zero balances during the year-

end close. If you want to keep inactive accounts with zero balances, mark this option and then 

select which accounts to maintain.   

With budget amounts - Mark to keep inactive accounts with zero balances that have budget 

amounts from being deleted during the year-end close process. Inactive accounts with zero 

balances and no budget amounts will be deleted. 

All inactive accounts - Mark to keep all inactive accounts from being deleted during the year-
end close process.  

To delete all inactive accounts with zero balances, unmark Maintain Inactive Accounts. 

4. Choose the Close Year button in the Year-End Closing window to begin the closing process.  
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Important: Click Close Year one time only. If you click more than one time, you will close more than one 

year during the process. Also, if the progress window appears to stop at 50 percent, do not restart the 

routine. As long as the hard disk is processing, let the process continue.  

Note: NEW FEATURE in Microsoft Dynamics GP 2013 and later versions - Status Bar - 

Depending on the amount of data you have in the GL, the closing process may take some time to 

complete. Microsoft has added a status bar to the Year-End Closing window. The process is 

broken down into seven steps and will display each step during the process. The steps are as 

follows: 

Step Description 

Step 1 Transactions and the retained earnings account are 
verified. 

Step 2 Account balances are verified. 

Step 3 Fiscal year information is verified. Posting numbers and 
transactions are reconciled. 

Step 4 Beginning balances are brought forward, retaining 
earnings are created and distributions are moved to 
history. 

Step 5 Divisional retained earnings account is closed. 

Step 6 Posting numbers used during the year-end close are 
updated. 

Step 7 The previous year is removed from the account summary. 

 

Note: In Microsoft Dynamics GP 2013 and later versions - Reverse Historical Year  

You will now have the option to Reverse Historical Year in the Year-End closing window for GP 2013 

R2 and later versions. Note this option is NOT to be used if you have a failed Year-end Close. If you 

receive any error messages during the close or have any issues with the Year-End Close process, 

you should restore from backup immediately. 

If you are maintaining the account history, the year-end closing routine transfers all current-year 

information for each account in the chart of accounts to the account history. If you are maintaining the 

transaction history, the year-end closing routine also transfers all current-year information for each 

account in the chart of accounts to the transaction history. The process then prepares the accounting 

system for a new fiscal year. Besides transferring current-year figures to the transaction history and to the 

account history, the year-end closing routine does the following:  
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• The year-end closing routine reconciles and summarizes the general ledger balances that 

accumulated throughout the year.  

• The year-end closing routine removes accounts that are marked as inactive if the accounts match 

the criteria for deleting a posting account. Inactive accounts that have been set up as budget 

accounts can also be deleted if they have no activity for the year. These accounts can be deleted 

even if budget amounts from past years are associated with these accounts.  

• The year-end closing routine moves all profit and loss account balances to the retained earnings 

account.  

• The year-end closing routine summarizes balance sheet accounts and brings the balances 

forward as the beginning balances of the account in the new fiscal year.  

• The year-end closing routine prints the Year-End Closing Report.  

When the year-end closing routine is complete, the Year-End Closing Report is printed. This report lists 

the accounts that were closed and the transactions that were created to close those accounts. The Year-

End Closing Report is part of the audit trail. Save this report for your company's permanent records. The 

Year-End Closing Report cannot be reprinted. 

Step 13: Close all fiscal periods for all series (Optional)   

To ensure that no one posts transactions to an incorrect period or year, use the Fiscal Periods Setup 

window to close any fiscal periods that are still open for the year. 

Go to Microsoft Dynamics GP > Tools > Setup > Company > Fiscal Periods  

Make sure that you have posted all transactions for the period and year for all modules before closing 

fiscal periods. If you later need to post transactions to a fiscal period you have already closed, use the 

Fiscal Periods Setup window to reopen the period before posting the transaction. Mark the periods you 

wish to close under the Financial Series. 

Step 14: Adjust the budget figures for the new year, and if you use Microsoft Dynamics GP 

Advanced Financial Analysis Reports, then print the financial statements. 

1. Adjust budget figures by using one of the following windows: 

• Excel-Based Budgeting  

• Budget Maintenance  

• Single-Account Budget Maintenance  

2. Print the Profit and Loss Statement to verify that profit and loss accounts were closed to the 

retained earnings account. Print the Balance Sheet to verify that the balance sheet accounts 

indicate that the balances were brought forward. 

If you are using Advanced Financial Analysis to print the financial statements, you must update the report 

layout to reflect the current fiscal year. To do this, follow these instructions: 
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1. Go to Reports > Financial > Advanced Financial.  

2. In the Reports list, select the Financial Statement, click Open and then click Layout.  

3. Double-click the first column heading.  

4. If the column type is set to Period Range, Year-to-Date or Variable Year-to-Date, select the 

current fiscal year in the Year list and then click OK.  

5. Repeat step 1 through step 4 for each column of each report.  

Step 15: Create Post Closing backup  

Make a backup after you close the year. Place the backup in safe, permanent storage. This backup 

ensures that you have a permanent record of the company's financial position at the end of the year and 

allows you to quickly restore the information in the event a power fluctuation or some other problem 

occurs during the year-end close procedure. See the section on Backups under General Tips and 

Reminders for more information on creating backups. 

Frequently asked questions  

Q1.  Do I have to close the fiscal year before the first day of my next fiscal year? 

The year-end closing routine does not have to be completed before you start your next fiscal year. 

However, we recommend that you close the year as soon as possible.  

Q2.  Can I make adjusting entries after I close the year? 

You can post an entry to the most recent historical year if the Posting to History checkbox is selected in 

the General Ledger Setup window. If you post an entry to a closed year, a second entry is automatically 

made that updates the beginning balances for the current fiscal year. 

The following tables show an adjusting entry and the way the entry appears in the posting journal. 

Adjusting Entry 

 12/25/2022 Administration Expenses $300 
   Cash    $300 
 

Posting Journal 

 12/25/2022 Administration Expenses $300 
   Cash    $300 
 12/31/2022 Retained Earnings  $300 
   Cash    $300 
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Q3.  After I performed the year-end closing routine, beginning balances were brought forward for 

some of my sales and expenses accounts. Some of my asset accounts also closed to the 

retained earnings account. Why did this problem occur, and what can I do to correct it? 

The posting type that is specified in the Account Maintenance window for the account determines whether 

a balance is brought forward for the account or whether the account is closed to the retained earnings 

account. Accounts that use the Balance Sheet posting type carry a balance forward. Accounts that use a 

Profit and Loss posting type close to the retained earnings account. To resolve this problem, restore from 

a backup, correct the posting type and then run the year-end closing routine again. 

If you are unable to restore from a backup, use one of the following methods depending on what posting 

type the account should have been. 

Method 1: The account should be a profit and loss account: 

As a balance sheet account, this account will have a beginning balance after the year-end closing 

process is complete. Follow these steps to change the account to a profit and loss account and to reverse 

the beginning balance: 

1 On the Cards menu, point to Financial and then click Account. In the Account Maintenance 

window, type the account number in the Account field. Make sure that the Posting Type area is 

set to Balance and then click Save. 

2 Use one of the following methods:  

If you are registered for Multicurrency Management, go to Microsoft Dynamics GP > Tools > 

Setup > Financial > Multicurrency. 

In the Maintain History area, click to select the General Ledger Account check box. 

If you are not registered for Multicurrency Management, follow these steps: 

Go to Start > All Programs > Microsoft SQL Server Version > click SQL Server Management 

Studio 

Run  the following statement against the company database: 

UPDATE MC40000 SET MNSUMHST = 0 

3 Change the Maintain History settings in the General Ledger Setup window. To do this, follow 

these steps:  

a.  Go to Microsoft Dynamics GP > Tools > Setup > Financial > General Ledger. 

b.  In the Maintain History area, click to clear the Accounts check box and the Transactions 

check box. 
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4. In the Allow area, click to select the Posting to History check box. Click OK. 

5. Verify fiscal period settings. To do this, follow these steps.  

a.  Go to Microsoft Dynamics GP > Tools > Setup > Company > Fiscal Periods. 

b.  In the Fiscal Periods Setup window, make sure that the fiscal period for the recently closed 

year is open. 

 

6. On the Transactions menu, point to Financial and then click General. In the Transaction Entry 

window, enter a transaction that reverses the incorrect beginning balance of the profit and loss 

account. In the Transaction Date field, enter a date that is in the closed fiscal year. 

 

For example, if the profit and loss account has an incorrect debit beginning balance of $100.00, 

create a transaction that credits the profit and loss account for $100.00 and then debit the 

retained earnings account for $100.00.  

7. Click Post.  

 

Note: The transaction updates only the current year because the Maintain History settings are 

not enabled. 

8. Change the Maintain History settings in the General Ledger Setup window. To do this, follow 

these steps:  

a.  Go to Microsoft Dynamics GP > Tools > Setup > Financial > General Ledger. 

b.  In the Maintain History area, click to select the Accounts check box and the Transactions 

check box. 

 

9. To post the transactions to the transaction history, click to select the Posting to History 

checkbox under Allow. If you do not want to post the transactions to the transaction history, click 

to clear this checkbox. Then, click OK. 

10. Use one of the following methods:  

• If you are registered for Multicurrency Management, follow these steps:  

a.  Go to Microsoft Dynamics GP > Tools > Setup > Financial > Multicurrency 

b.  In the Maintain History area, click to select the General Ledger Account checkbox. 

 

• If you are not registered for Multicurrency Management, follow these steps:  
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Method 2: The account is supposed to be a balance sheet account  

As a profit and loss account, this account will not have a beginning balance after the year-end closing 

process is complete. Follow these steps to change the account to a balance sheet account and to create 

the beginning balance:  

1. On the Cards menu, point to Financial and then click Account. In the Account Maintenance 

window, type the account number in the Account field. In the Posting Type area, click Balance 

Sheet and then click Save. In the Account Type area, click Balance Sheet, so that the 

correcting entry that you make in step six later in this section will correctly update the beginning 

balance for the current year. 

2. Use one of the following methods:  

• If you are registered for Multicurrency Management in Microsoft Dynamics GP, follow these 

steps:  

a.  Go to Microsoft Dynamics GP > Tools > Setup > Financial > Multicurrency. 

b.  In the Maintain History area, click to clear the General Ledger Account check box. 

 

• If you are not registered for Multicurrency Management, follow these steps:  

 a. Go to Start > All Programs > Microsoft SQL Server Version > click SQL Server 

Management Studio.  

b.  Run the following statement against the company database:  

UPDATE MC40000 SET MNSUMHST = 0 

 

 

3. Change the Maintain History settings in the General Ledger Setup window. To do this, follow 

these steps:  

a. Go to Start > All Programs > Microsoft SQL Server Version > click SQL Server 

Management Studio  

b.  Run the following statement against the company database:  

UPDATE MC40000 SET MNSUMHST = 1 

 

 

11. On the Cards menu, point to Financial and then click Account. In the Account Maintenance 

window, type the account number in the Account field. In the Posting Type area, click Profit 

and Loss and then click Save. 
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a.  Go to Microsoft Dynamics GP > Tools > Setup > Financial > General Ledger. 

b.  In the Maintain History area, click to clear the Accounts check box and the Transactions 

check box. 

 

4. In the Allow area, click to select the Posting to History check box and then click OK. 

5. Verify fiscal period settings. To do this, follow these steps:  

a.  Go to Microsoft Dynamics GP > Tools > Setup > Company > Fiscal Periods. 

b.  In the Fiscal Periods Setup window, make sure that the fiscal period for the recently closed 

year is open. 

 

6. On the Transactions menu, point to Financial and then click General. In the Transaction Entry 

window, enter a transaction that creates the correct beginning balance of the balance sheet 

account. In the Transaction Date field, enter a date that is in the closed fiscal year. 

 

For example, if the balance sheet account should have a debit beginning balance of $100.00, 

create a transaction that credits the retained earnings account for $100.00 and that debits the 

balance sheet account for $100.00. 

7. Click Post. 

 

Note: The transaction updates only the current year because the Maintain History settings are 

not enabled. 

8. Change the Maintain History settings in the General Ledger Setup window. To do this, follow 

these steps:  

a.  Go to Microsoft Dynamics GP > Tools > Setup > Financial > General Ledger 

 

b.  In the Maintain History area, click to select the Accounts check box and the Transactions 

check box. 

 

9 To post the transactions to the transaction history, click to select the Posting to History 

checkbox under Allow. If you do not want to post the transactions to the transaction history, click 

to clear this checkbox. Then, click OK 

10 Use one of the following methods: 

• If you are registered for Multicurrency Management, follow these steps: 

 

1. Go to Microsoft Dynamics GP > Tools > Setup > Financial > Multicurrency. 
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2. In the Maintain History area, click to select the General Ledger Account checkbox. 
 

• If you are not registered for Multicurrency Management, follow these steps: 

a. Go to Start > All Programs > Microsoft SQL Server Version > click SQL Server 

Management Studio.  

b. Run the following statement against the company database:  

 

 UPDATE MC40000 SET MNSUMHST = 1 

 

Q4.  I tried to run the year-end closing routine by using a divisional retained earnings account, but 

I received the following error message: “Retained Earnings account not found.” What can I 

do to resolve the problem that causes this error message? 

Before the routine can continue, the year-end closing routine must validate that all the required 

divisional retained earnings accounts exist. For example, the Fabrikam Inc demonstration company 

uses an account format of nnn-nnnn-nn. The first segment represents the department. A retained 

earnings account must exist for each department that has a profit and loss account. For example, if 

sales account 400-4100-00 exists, but no 400-nnnn-nn retained earnings account exists, you receive 

this error message. 

Q5.  What happens to unit accounts during the year-end closing routine? 

Microsoft Dynamics GP 2010 and prior versions:  

Unit accounts are treated as balance sheet accounts. Unit accounts have a balance that is brought 

forward when the year is closed. 

How to delete balances for unit accounts in the current year: 

1. Go to Start > All Programs > Microsoft SQL Server Version > click SQL Server Management 

Studio.  

2. Run the following statement against the company database:  

a. Delete GL20000 from GL00100, GL20000 where GL00100.ACTINDX = 

GL20000.ACTINDX and GL00100.ACCTTYPE = 2 and GL20000.SOURCDOC = 

'BBF.' 

3. Go to Tools > Utilities > Financials > Reconcile.   

4. In the Reconcile Financial Information window, mark the Year checkbox.  
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5. Reconcile each year. Start the process by using the oldest historical year. End the process by 

using the current open year.  

How to delete balances for unit accounts in historical years 

Go to Start > All Programs > Microsoft SQL Server for your Version > click SQL Server Management 

Studio.  

1. Run the following statement against the company database:  

2. Delete GL30000 from GL00100, GL30000 where HSTYEAR = 'XXXX' and 

GL00100.ACTINDX = GL30000.ACTINDX and GL00100.ACCTTYPE = 2 and 

GL30000.SOURCDOC = 'BBF.' 

3. Go to Tools > Utilities > Financials > Reconcile.   

4. In the Reconcile Financial Information window, mark the Year checkbox.  

5. Reconcile each year. Start the process by using the oldest historical year. End the process by 

using the current open year. 

Microsoft Dynamics GP 2013 and later versions 

There is new functionality in Microsoft Dynamics GP 2013 and later versions that will clear out the unit 

account balances automatically as part of the GL year-end close process. Follow these steps: 

 

1. Prior to closing the GL year, click on Cards, point to Financial and click Unit Account.  

2. Select the unit account and mark the checkbox for Clear Balance During Year-End Close.  

3. Click Save. Do this for each unit account that you wish to have the beginning balance set to zero 

for the new year, as part of the GL year-end close process. 

Note: The manual process listed above for prior versions of Microsoft Dynamics GP would also work as 

well, but it is recommended to use the new functionality in Microsoft Dynamics GP going forward. 

Q6.  I am preparing to close the year in general ledger. Must everyone exit Microsoft Dynamics GP 

or Microsoft Business Solutions - Great Plains before I perform the year-end routine? 

We recommend that client computer users stop work in Microsoft Dynamics GP or in Microsoft 

Business Solutions - Great Plains while the year-end closing routine is processing. If users continue 

to work in the program, transactions may have to be entered again if problems occur during the year-

end closing routine. 

Q7.   I want to allocate the net profit to the retained earnings account or to the capital accounts 

each month. Also, net profit is supposed to be allocated to three retained earnings accounts 

or capital accounts. Can I do this? 
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No, you cannot do this. However, you can specify a nonfinancial account in the Account 

Maintenance window. Use a number that is not in your current account numbering scheme. This 

account acts as a suspense account for the net income or for the net loss. Every month, you can 

post an adjusting entry to the three capital accounts that you want to adjust. For the offset account, 

use the suspense account. When the year-end closing routine is finished, use the suspense account 

as the retained earnings account. This offsets all the manual adjustments that you made to the 

suspense account during the year. Make sure that the suspense account does not appear on 

reports. 

If you are using Advanced Financial Analysis for financial statements, when you format the balance 

sheet, use the Net Profit (NP) line as the last line on the Advanced Financial Analysis statement. 

Then, put a page break before the NP line. The balance sheet must have an NP line. However, this 

line makes the net income or the net loss appear two times. Therefore, format the NP line, so that it 

is kept off the financial statement. You can also use a report type of Other. 

Q8.  Why is the status of some of my financial reports set to Invalid? 

If a report is configured to use the accelerator file, any changes that are made to accounts in any 

one of the following windows causes the status of the financial report printing options to change to 

Invalid: 

• Account Maintenance  

• Unit Account Maintenance  

• Mass Modify Chart of Accounts  

• Year-End Closing  

Before you print financial statements, you must update the accelerator file. To do this, follow these 

steps: 

• Go to Reports > Financial > Update Financial Accelerator.  

• Click Update and then click Continue.  

• Close the Update Financial Accelerator Information window. 

Q9.  How are nonfinancial accounts closed during the year-end closing routine? 

If the nonfinancial account is configured to use the Balance Sheet posting type, the account balance 

is brought forward during the year-end closing routine. If the nonfinancial account is configured to 

use the Profit and Loss posting type, the account balance is closed to the retained earnings account 

during the year-end closing routine. 
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Q10.  When I try to post a batch in the General Ledger module, I receive the following message: 

“Batches cannot be posted while the Year-End Close is in progress.” The year-end closing 

routine is not being run in general ledger. What should I do? 

To resolve this issue, have all users close all transaction entry windows. Then, delete the SY00800 file if 

you are running a Microsoft SQL Server database. To do this, run the following statement on the 

DYNAMICS database:  

  Delete SY00800 where BACHNUMB = 'GL_Close.' 

Q11.  I receive the following message when I try to close the year in general ledger: “Sorry, 

another user is closing the year.” No one else is trying to close the year. What should I do? 

To resolve this issue, delete the SY00800 file if you are using a Microsoft SQL Server database. To do 

this, run the following statement in SQL Query Analyzer on the DYNAMICS database: 

  Delete SY00800 where BACHNUMB = 'GL_Close.' 

Q12.  I am performing the year-end closing routine in general ledger and it appears to be 

stopped at 50 percent. My workstation seems to have stopped responding. What should I do? 

If the year-to-date transaction open file (GL20000) is large, it may take a long time for the year-end 

closing routine to finish. If the hard disk is still processing, the year-end closing routine has not stopped 

responding. We recommend that you let the routine run. If the hard disk is not processing, we recommend 

that you restore from a backup. Then, follow the steps in this article again, starting at step five. 

Q13.  If an adjusting entry has been posted to a year that is closed, can I print a corrected Trial 

Balance report for that year? 

Yes, you can print a corrected Trial Balance report for the year that is closed. To do this, follow these 

steps: 

1. Go to Reports > Financial > Trial Balance> New.  

2. In the Option field, type With Adjustments.  

3. In the Include area, click to select the Posting Accounts checkbox.  

4. In the Year area, click to select the History checkbox and then select the historical year in the 

Year list.  

5. Click Destination to specify a report destination and then click OK.  

6. Click Print. 

Q14.  How does Microsoft Dynamics GP determine the financial statement that is printed for the 

account that I am adding? 
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The category determines the type of financial statement that is printed when you use quick financial 

statements for the account that you are adding. The category is either the Balance Sheet category or the 

Profit and Loss category. You must format the reports to print the accounts that you want in Advanced 

Financial Analysis and in Microsoft FRx. The posting type is used during the year-end closing routine to 

determine the accounts that close to the retained earnings account and to determine the account that 

carries a balance forward. The posting type does not affect the financial statements. 

Q15.  When I tried to perform the year-end closing routine, I received an error message that 

stated that a single-use batch or a quick journal transaction had not been posted. What does 

this error message mean? 

When you try to perform the year-end closing routine, you may receive the following error message: “A 

single-use batch or quick journal transaction has not been posted yet. Do you want to continue closing?” 

You receive this error message if an unposted single-use batch or an unposted quick journal transaction 

exists in general ledger. This error message does not prevent you from continuing with the year-end 

closing routine. If you do not want to post the single-use batch or the quick journal transaction, continue 

with the year-end closing routine. 

Q16.  When I try to perform the year-end closing routine in general ledger, why do I receive the 

following error message: “[Microsoft][ODBC SQL Server Driver][SQL Server]Violation of 

PRIMARY KEY constraint 'PK##0671112'. Cannot insert duplicate key in object '##0671112'”? 

The year-end closing transactions contain a currency that is not assigned to an account. 

To resolve this problem, assign the currency to the appropriate account. To do this, follow these 

steps:  

1. Have all users exit Microsoft Dynamics GP.   

2. Restore a backup of the company database that was made before you tried to perform the 

general ledger year-end closing routine.   

3. Go to All Programs > Microsoft SQL Server for your Version > click SQL Server Management 

Studio: 

• Run the following script against the company database: 

• Select CURNCYID FROM GL20000 

• Make note of all currencies displayed in the CURNCYID column.   

• Start Microsoft Dynamics GP, and then log in as user “sa.”   

4. Go to Cards > Financial > Account:   

• In the Account field, type the retained earnings account number.   

• Click Currency.  

• In the Select Account Currencies window, mark the Currency ID checkboxes that you  

noted in  
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• Step five. Perform the year-end closing routine in general ledger.   

Q17.  Why did the year-end closing process delete some GL accounts that may be tied to 

budgets? 

 

 In Microsoft Dynamics GP 2010 and Microsoft Dynamics GP 10.0, the year-end closing 

process will automatically delete GL accounts that are marked as inactive and have no activity 

in the current year. In Microsoft Dynamics GP 2013 and later versions, there is new 

functionality in the Year-End Closing window to Maintain Inactive Accounts. This allows you 

to have inactive accounts without a balance automatically deleted, or to maintain all inactive 

accounts or just those used in Budgets. For more information on the new features, click 

HERE: 

• (http://www.youtube.com/watch?v=ZZFtSrpMm5A&feature=youtube)  

• . For more information about inactive GL accounts and the year-end close process, click the 

following article number to view the article in the Microsoft Knowledge Base:  

• 2452542 

• (http://support.microsoft.com/kb/2452542/ )  

• Inactive GL accounts deleting during the Year-End Close process for general ledger in 

Microsoft Dynamics GP  

Q18.   

 

If I had a failed year-end close, can I use the Reverse Historical Year checkbox in the Year-End 

Closing window in Microsoft Dynamics GP 2013 R2 and later versions to try to fix it or ”un-do” 

it? 

 

No, if you had an error message or a failed year-end close, you should make a screen printing 

of the error message and restore to a backup immediately. Open a support incident with 

Microsoft Dynamics Support for further assistance. (The Reverse Historical Year checkbox in 

Microsoft Dynamics GP 2013 R2 and later versions should only be used to reopen a GL year 

that was successfully closed and should not be used to troubleshoot a failed year-end close.)  

 

How to set up an adjusting period In general ledger 

This section describes how to set up an adjusting period to record adjustments that are posted to the 

general ledger after the year-end close process has been performed. The adjusting period that you set up 

should meet the following conditions:  

• The adjusting period should start on the last day of the fiscal year.   

• The adjusting period should not overlap any other period dates.   

http://www.youtube.com/watch?v=ZZFtSrpMm5A&feature=youtu.be
http://support.microsoft.com/kb/2452542
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To set up an adjusting period in general ledger in Microsoft Dynamics GP, follow these steps. 

Note:  Historical periods cannot be changed. This example assumes that the fiscal year starts on January 

1 and ends on December 31, and that the fiscal year has a 13th adjusting period. 

1. Go to Microsoft Dynamics GP > Tools > Setup > Company > Fiscal Periods.   

2. Set up each fiscal period. To do this, see the steps in the following example. In the Year list, click 

a year. For example, click 2023.   

3. In the First Day field, type a first day for the fiscal period. For example, type 01/01/2023.  

4. In the Last Day field, type a last day for the fiscal period. For example, type 12/31/2023.   

5. In the Number of Periods field, type the number of periods for the fiscal year. For example, type 

13.   

6. Click Calculate.   

7. If it is necessary, adjust the start dates of the periods. In this example, type dates in the Date 

column beside the corresponding entry in the Period Name column, as indicated in the following 

list: 

- Period 1: 01/01/2023  

- Period 2: 02/01/2023  

- Period 3: 03/01/2023 

- Period 4: 04/01/2023  

- Period 5: 05/01/2023  

- Period 6: 06/01/2023 

- Period 7: 07/01/2023  

- Period 8: 08/01/2023  

- Period 9: 09/01/2023  

- Period 10: 10/01/2023  

- Period 11: 11/01/2023 

- Period 12: 12/01/2023 

- Period 13: 12/31/2023  

8. Click OK.  

9. Go to Microsoft Dynamics GP > Tools > Utilities > Financial > Reconcile. 

10. Click to select the Year checkbox.  

11. Click Reconcile. Microsoft Dynamics GP reconciles the account summary data to the account 

detail data for all general ledger accounts.   
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Analytical Accounting year-end closing procedures 

When the year-end close process is run for general ledger in Microsoft Dynamics GP, it automatically 

moves the Analytical Accounting transactions from the AAG30000 historical tables to the AAG40000 

series tables. There is no separate Year-End closing procedure that must be run in Analytical 

Accounting. You may select which dimensions that you want to be consolidated during the year-end 

process. In Analytical Accounting, Balance Brought Forward entries are created in the AAG30000 tables 

for those dimensions that were marked to be included in the year-end process and then the detail is 

moved to the AAG40000 series tables.    

 

Analytical Accounting year-end checklist 

1. Determine if financial reports use AA or GL tables 

2. Verify AA data for overlapping years 

3. Verify the years between Open/Historical tables match between AA/GL and move data to History 

for the earlier closed years, if applicable. 

4. Check AA tables for Overlapping Header IDs 

5. Update AACOPYSTATUS values 

6. Review Setup for Dimensions to be included in Year-End 

7. Run GL Year-End Close process to move AA balances and create BBFs. 

8. Verify Balance Sheet reports 

Detailed information for each step in the year-end checklist  

Step 1:   Determine if financial reports use AA or GL tables  

Prior to running the general ledger Year-End close or proceeding with any of the steps in this article, run 

your financial reports that you normally run to the GL Trial Balance. Based on the results, follow the 

appropriate method: 

Method 1: If your Financial reports are CORRECT and match GL, then you may proceed with steps 2-8 in 

this article, which still must be completed to prevent receiving any AA errors during the GL year-end close 

process.  

Note: If you use a reporting system that only reads directly from GL tables and not AA tables (such as 

Legacy in Management Reporter or FRx Reporting) for your financial reports, then you may continue on, 

since AA data does not affect your financial reporting.  
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Method 2:  If your financial reports are NOT CORRECT, you will need to verify the AA data against GL 

data.  

Note: Data Mart in Management Reporter reads directly from AA tables, so these customers may need to 

verify the AA data. To do this, you will need to complete steps 2-6 below, as well as run the additional 

scripts that will be linked here in step one.  

 

Steps for Method 2: 
 

a. First, run all the scripts in KB 2910626 to verify AA data with GL data. If you find inconsistencies 

between your financial reports and the general ledger trial balance reports, please visit the link below and 

review the article entitled: Financial Reports from Management Reporter do not match the General 

Ledger Trial Balance reports in Microsoft Dynamics GP. http://support.microsoft.com/kb/2910626   

b. When you have completed the steps in KB 2910626, continue on with the rest of the steps listed below. 

(Note that step two and step four are also in KB 2910626, but we recommend double-checking this again, 

as they should not return any results if you already fixed this data.) 

Step 2:   Verify AA data for overlapping years 

Run the scripts below to make sure you do not have overlapping years in the AAG30000 Open table with 

the AAG40000 historical table. Each distinct year should only exist in one table or the other, but not both.  

select distinct(YEAR1) from AAG30000 

select distinct(YEAR1) from AAG40000 

If you find overlapping years in both tables, contact your local RSM support representative for further 

assistance.  

Step 3: Verify the year between Open/Historical tables math between AA/GL: 

Next, make sure the years found in the AA tables are in the same open or closed years as your GL 

tables. The AAG30000 and GL20000 open tables should have the same years. And the AAG40000 and 

GL30000 historical tables should contain the same closed years. Run the scripts below: 

select distinct(YEAR1) from AAG30000 

select distinct(OPENYEAR) from GL20000 

select distinct(YEAR1)from AAG40000 order by YEAR1 

select distinct(HSTYEAR) from GL30000 order by HSTYEAR 

If you find years in the AAG30000 open table PRIOR to the year you are closing, you must also follow the 

STEPS TO MOVE DATA TO HISTORY below, as well move the historical year data to history. The 

AAG30000 table should only have data for the years that are currently open years in the GL. If you 

attempt to close the year in GL, you will be prompted with this message:   

http://support.microsoft.com/kb/2910626
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You must run the consolidate transactions and transfer detail to history utility for closed years to 

recreate the Analytical Accounting Balances Brought Forward. 

It is important to run these scripts to determine if you need to run the STEPS TO MOVE DATA TO 

HISTORY to prevent this error during the GL year-end close process. 

STEPS TO MOVE DATA TO HISTORY: 

 The first time you close the General ledger on a version other than GP 10.0 SP2 or with AA 

activated, you will need to move AA data to history before the system will allow you to close the 

year in the General Ledger.  The system will verify the AA data is in the corresponding 

open/historical series of AA tables, as the GL data sits in the open/historical tables in GL. If this is 

not the case, you will receive a message to run the Move to History Utility for AA before you can 

proceed with the GL Year-End close.  

 

Note: If you have not closed your GL year (with AA activated) after installing a service pack later than 

SP2 for version 10.0, or upgrading to GP 2010, you may receive a message stating: "You must 

consolidate transactions and transfer detail to history utility to close the year." Code was added to the 

closing process that will compare the years in the AA open tables against the historical years in the 

Company Fiscal Period Setup. If there is AA data in the AAG3000X series of tables for a historical year, 

you will receive the error. Follow these steps to consolidate those years:    

 

1.) On the Microsoft Dynamics GP menu, go to Tools > Utilities > Financial > Analytical Accounting.  

Then click Move Data to History.  

 

2.) The oldest year will default in that the system found in the open AAG3000x tables. You will only be 

able to move one year at a time.  

 

3.) Select the appropriate option:  

 

Transfer transaction detail to history – This option will move the AA detail records from open to history 

tables and no BBF entries will be created. You must ensure there are no BBF entries in the AA tables, 

otherwise you will not be able to select this option. This option just moves the records from the 

AAG30000 tables to the AAG40000 tables.  

 

Consolidate transactions and transfer detail to history – This option will move the AA detail records 

from open to history tables and create BBF entries. However, you must have the options mentioned 

previously selected, in order for BBF entries to be created. This option will consolidate the balances of all 

the transaction dimension codes in the closed year (that are marked to be consolidated) and transfer the 

AA information to the history tables.  

 

Note: The consolidated balances are brought forward to the new year. BBF entries are created from the 

closed years. 

 

Print transfer preview report only – This report will preview the transactions that will be moved without 

actually moving the data. The preview report displays the consolidations that will be made.  
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Note: This option does not change data.  

 

4.) Click OK.  

 

5.) Repeat this process for each “historical” year, where the year is in the AAG30000 open table, but not 

in the GL30000 history table. The year needs to be moved to the AA history table to match. 

Note: If you rerun the distinct year scripts in “STEP 3” above again, you should get the distinct years to 

match between open AA and GL tables and historical AA and GL tables. 

Step 4: Check AA tables for overlapping header IDs 

Run the following script against the company database to check to see if the same header IDs also exist 

between the tables: 

Select * from AAG30000 where aaGLHdrId in (select aaGLHdrld from AAG40000) 

If you find duplicate header IDs in both tables, contact your local RSM support representative for further 

assistance.  

 

This issue may occur if you restored an older Dynamics database over the top of the current Dynamics 

database, and so the next available numbers stored in the AAG00102 table in the Dynamics database 

are set back. GP continues to increment from these values, even though they may already have been 

used, and would result in the same aaGLHdrID value getting used for different YEAR1 values.  

 

Step 5: Update AA Copy Status values 

Run the following script to check for an incorrect aacopystatus value in the AAG40001 table: 

select count(*) from AAG40001 where aaCopyStatus<>8  

If the script above returns results, you will want to update the aaCopyStatus to “8” before running the GL 

Year Close: (The value of “8” is a value that the year-end close process will accept.) 

update AAG40001 set aaCopyStatus=8 

Step 6: Review setup for dimensions to be included in year-end 

Verify that you marked the AA dimensions that you want to be included in the year-end close, so that AA 

codes are linked to the Balance Brought Forward journal entries.  

 

If you have not closed general ledger yet, follow these steps to make sure the dimension is marked 

correctly to be included in the close process:  

1. Mark the setup option to include Analytical Accounting in the year-end close as follows:  
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a. Go to Microsoft Dynamics GP > Tools > Setup > Company > Analytical Accounting 
and click Options.  

b. Click to select the Include in Year-End Close checkbox and then click OK.  
 
Note: This option is just to enable the functionality to create Balance Brought Forward 
entries on the dimensions. The Analytical Accounting data will still move to the 
AAG40000 series tables when general ledger is closed, regardless of whether this option 
is marked.  

 

2. Individually mark the dimensions to be included in year-end as follows:  
 

Go to Cards > Financial > Analytical Accounting and click Transaction Dimension.  
 
a. In the Trx Dimension list, click the dimension that you want to include in the year-end 

close process.  
b. In the Year-End Close area, click to select the Include in Year-End Close checkbox 

and then click Save.  
c. Repeat for each dimension that you want to include in the year-end close process.  

Step 7: Verify AA Account Master 

Verify that the AA Account Master table (AAG00200) matches the GL Account Master table (GL00100) 
before you process a year-end close. If accounts are missing, it would cause the BBF entries in AA to be 
incorrect. Run the scripts below against the company database to verify that the GL Account Master, GL 
Account Index Master, and AA Account Master tables all have the same number of records: 
 
select count(*) from GL00100 
select count(*) from GL00105 
select count(*) from AAG00200 
 
• If the AA Account Master table has LESS records than the GL00100 table, use the script below to insert 
the missing GL accounts:  
 
insert into aag00200  
ACTINDX, aaAcctClassID,aaChangeDate,aaChangeTime) 
select ACTINDX, 0, convert(char(10),getdate(),111), convert(char(12),getdate(),114) 
from GL00100 where ACTINDX not in (select ACTINDX from aag00200) 
 
• If the AA Account Master table has MORE records than the GL00100 table, use the script below to 
remove the extra records: 

delete AAG00200 where ACTINDX not in (Select ACTINDX from GL00100) 

• If the GL00105 table doesn't match, refer to KB 855963 for steps on How to Recreate the Account 

Master Index table (GL00105).  

Step 8: Run GL Year-End Close process to move AA balances and create BBF's.  

Always make a current backup before starting the GL year-end close process. It is recommended to test 

running the GL year-end close in a test company first to ensure you do not get any errors. The GL year-

end close process is what actually creates the Balance Brought Forward journal entries (BBFs), and 

http://support.microsoft.com/kb/855963
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moves the records for the year that you are closing in both general ledger and Analytical Accounting 

tables. BBF entries are created in both GL and AA tables. Refer to the section in this document for year-

end closing procedures for general ledger. 

Step 9:  Verify Balance Sheet accounts 

It is recommended to compare the Balance Sheet report in Management Reporter to the General Ledger 

Trial Balance report from Microsoft Dynamics GP, to verify that the account balances brought forward to 

the new year are correct. If these balances do not match, restore to your backup and contact your RSM 

support representative to open a support incident for additional assistance.  
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